RoundCube Frustration

apps

#1

I’ve been trying to setup roundcube for the last couple of days and I’m getting no where. I’ve read all the forum posts and articles on getting it to work on dreamhost, still nothing.

I even just manually edited all the include/require paths to make sure it was finding everything, once the ‘cant find x include’ errors are gone I get nothing, just a blank screen. I’m yet to see the login screen. What is going on?

I’m using the latest CVS, I ideally want it to work with php5 (running as CGI) but I’ve also tried switching to php4 (as apache module). Any clues?

Any help will be greatly apriciated,
Rich.


#2

I’m currently trying to get it working as well. I’ve got my working and able to log in. I’m just trying to figure out the virtual users so that I can log in as my user and not m12435123.

Something that can help you is to turn on error reporting at the top of the main.inc.php. It’s set to ‘1’ be default. Change it to ‘4’ and reupload and refresh. That will at least let you know what’s wrong and not just a blank screen.


#3

Rich I’ve just installed Roundcube to see if there were any problems. It seems to have installed okay (I had to do some manual fiddling with the database and use a test db because DH takes too long to make the subdomains available :wink: . But that was just local to me)

Still if you’ve followed the wiki exactly you should be almost there.
In the config folder apart from .htaccess are the two include files that you have to update as per the wiki.
What I had to do though was copy
db.inc.php.dist to db.inc.php
and likewise
main.inc.php.dist to main.inc.php

since my tarball only came with the two distrib files. (Perhaps the wiki needs updating there?)

The rest is just following the wiki in order. Ignore some references to line numbers they appear to be a bit out.

If you still have a blank page carefully check you have entered the MySql username correctly in db.inc.php.

When logging into Roundcube I didn’t use the full username address just the m number and password.

First impressions of RoundCube? I’ll probably stick with Squiddle :slight_smile:


Norm


#4

Thanks for the replies. I just got it working, the only thing I did differently was type the include_path instead of cutting and pasting the line from this Roundcube on Dreamhost article. Cheers for the tip on the error reporting, don’t know how I missed it.

I couldn’t find much info on virtual users, just this. I’m just using the ‘alias’ field in the users table atm.

Let us know how you get on.

Cheers,
Rich.


#5

I’ve followed the instructions for installing RoundCube from the wiki, and I can login successfully to my webmail. However, the language settings do not appear to be working. I have it set to English (US), but all I get is the placeholders for the labels. The placeholders all have square brackets (for example, [inbox] for Inbox, [addressbook] for Address Book, etc.). It looks like RoundCube is not finding the correct language files. Anybody else run into this issue and have a resolution? Thanks!

  • Chris

#6

Do you have a skins folder in place containing a folder called default?

Under ‘default’ should be several folders including ‘images’ and in the ‘images’ folder is the ‘buttons’ folder. Check that images in the buttons folder exist and permissions set to 644.

Also check that you updated the path settings string correctly complete with the ; at the end. (The one that starts “ini_set(‘include_path’,” )


Norm


#7

Yes, I’ve checked both of these, and they seem to be correct. I would think that if ini_set is not correct, then the site wouldn’t work at all. But the site does work (I can log in, see e-mails, etc.). In addition, all of the buttons are showing up. Just the text labels have the placeholders, not the actual text.

Here’s what my ini_get(‘include_path’) outputs after the ini_set call:
.:/usr/local/lib/php:/dh/cgi-system/:program:program/lib

This doesn’t seem correct, but I have exactly what’s listed on the wiki.

Also, are there any specific settings to the .htaccess files that I might need to adjust?

  • Chris

#8

This is what is in my index.php file at the required place.

// RC include folders MUST be included FIRST to avoid other
// possible not compatible libraries (i.e PEAR) to be included
// instead the ones provided by RC
//ini_set(‘include_path’, $INSTALL_PATH.PATH_SEPARATOR.$INSTALL_PATH.‘program’.PATH_SEPARATOR.$INSTALL_PATH.‘program/lib’.PATH_SEPARATOR.ini_get(‘include_path’));
ini_set(‘include_path’, ini_get(‘include_path’).PATH_SEPARATOR.$INSTALL_PATH.PATH_SEPARATOR.‘program’.PATH_SEPARATOR.‘program/lib’);

I just commented out the existing line and added the new line in.


Norm


#9

I actually just typed in my install path directly, rather than using the “figure out my install path” code. I know it’s hardcoding a file path which is a no-no, but since I don’t have to deploy this for multiple clients, it worked for me.

See here:
http://discussion.dreamhost.com/showflat.pl?Cat=&Board=3rdparty&Number=34357


#10

Thanks to everyone for the help. I ended up reinstalling RoundCube and using the absolute path for $INSTALL_PATH. That seemed to do the trick.

However, I still can’t send any mail. I have my SMTP server setup, username, and password setup in the main.inc.php file. But I keep getting an error when I try to send e-mail. One curious item is that under Sender I see the username then <username@>. Should the domain be there as well? It’s not clear to me what should be there.


#11

This is my portion of the file main.inc.php altered to protect the innocent.

// use this host for sending mails.
// to use SSL connection, set ssl://smtp.host.com
// if left blank, the PHP mail() function is used
$rcmail_config[‘smtp_server’] = ‘mail.example.com’;

// SMTP port (default is 25; 465 for SSL)
$rcmail_config[‘smtp_port’] = 25;

// SMTP username (if required) if you use %u as the username RoundCube
// will use the current username for login
$rcmail_config[‘smtp_user’] = ‘%u’;

// SMTP password (if required) if you use %p as the password RoundCube
// will use the current user’s password for login
$rcmail_config[‘smtp_pass’] = ‘%p’;

Your ISP does not intercept port 25? If so try port 587.


Norm


#12

Okay, I figured it out. I needed to update the profile of the user to match the correct e-mail address (this is stored in the identities table). I imagine this is how the SMTP server does some validation. Anyway, it’s working. Thanks for the help!