Replacing an image through FTP

design

#1

I have one thing I want to do on my website. Replace one image with another. Went to WebFTP, assets, images. Deleted the photo I want gone. Renamed the replacement the same as the one I deleted. Uploaded the replacement. Saved.

Old image still showing up. I want to avoid having to ask my web designer to do simple tasks. But this simple task is apparently not as simple as I thought. Or I’m just too simple to figure it out.

Any advice. Talk to me like I’m 6 years old. I’m much older, but have the HTML sophistication of a 4 year old.


#2

most likely an image cache that needs to be cleared. What web app is this that the site was built with?


#3

I have no idea. It was done about 3 years ago and I lost touch with the designer.


#4

can you give us the URL, maybe we can look at the page source and guess.

Do you have the web apps admin login information?


#5

Sure sounds like a cache issue to me. Go back to your website and to make sure you are loading the most current information from the server hit ctrl+f5 (clearing your browser cache would work too).


#6

Here’s the URL to the image: http://www.williefrancis.com/inside/html/author.html

As far as web apps admin login info…I’m able to access html through the Dreamhost FTP. I’ve gone in and made text changes on my website before. But never tried to swap a photo. So I’m not sure if that’s what you mean.

[hr]
Just tried that and it doesn’t seem to be working.


#7

I’m going to assume your updating the author pic, since any other picture on the page wouldn’t really make sense without other changes to the site.

…/assets/images/GilbertKing.jpg

is that the image you replaced? did you pay close attention to capitalization? In the windows world GilbertKing.jpg Gilbertking.jpg gilbertking.jpg would all be the same file… in the *nix world they are not. This is probably not the case as you said you removed the old file, which would mean that I would be seeing a page error most likely if this was the issue.

After seeing the page source for that page, it appears it’s not being created by a dynamic web app such as wordpress as I earlier assumed. This should be as simple as changing the file as you suggested, the only real mistakes I could see that could be made are the capitialization issue mentioned, or if the original designer left some trash about the server and there are for some reason more than one /assets/images/ folders. One thing you can do to test to see if you have found the correct file to replace is to rename or remove the file and then visit the site (forcing page reload from the server with shift-f5) to see if the page breaks (shows a mess or errors, because there is a missing file)

Final thought goes back to original thoughts of image cache… When I wrote originally I was thinking about a server side image cache to improve performance, Ryo-ohki has a similar thought and suggested your local browser cache and neither appear to be the case. But just for giggles I’ll take a screenshot as I see the page this morning (I’ve never been to the page before, so I can’t have the old image in my cache, but i don’t know how to tell if I’m seeing new or old.) and send you a private message on this forum with a link to my screenshot. This way we can eliminate a persistent browser caching issue for sure.


#8

Thanks, LakeRat. I’m going to try that right now. I may have messed that up.


#9

LakeRat fixed this for me! Thanks, LakeRat. I was uploading and deleting the image from the wrong “image” folder.


#10

I’m having a similar problem. I am uploading html pages and images via Windows XP FTP and my old files with the exact same names are staying in my files after I save over them. I am not using an web application to make changes; just using Komodo edit 6 to change code and saving over the old files on the server. Does anyone know how to fix this problem?


#11

I guess no would be the answer?


#12

When you look at the files you changed on your computer did the changes actually get saved? When you uploaded them and then viewed them on the web, if they looked the same did you clear your cache or use CTRL+F5 so that it pulls files directly from the site instead of a cached version you may have? Are you uploading the files to the proper directory?


#13

Yes, yes and yes.


#14

Have you checked the permissions of the directory you are uploading to and also the permissions of each file to make sure they are set so you can modify them? I remember a long time ago the permissions on my files changed (wasn’t here on dh though) and I did not have permission to modify them. My ftp program did not give me an error when I was uploading. The optimum is 644 that gives the ‘owner’ permission to read/write and group and public read permission.


#15

website is working but images are not dispalyingit is a wordpress website


#16

Is it hosted at dreamhost? or is it a wordpress.com site? what exactly are you seeing? can you provide us a link or domain name so that we can see? The real page is best because we can help you look at page source for clues and understand what the problem might be.

By the way… you should have started you own thread rather than reviving a very old thread for 2011 that doesn’t seem to be relevant to your issue to begin with…


#17

Thank you @Lakerat, good suggestion: let’s close this thread and open a new one with all the details.