Removing "www." from domain of existing Wordpress site

wordpress

#1

Apologies if this has been covered before, but our search turned up no good answers.

We’re trying to set up Wordpress’s multi-site network, but we’re told that we have to remove the www. from our domain before doing so. Unfortunately, when we choose “Remove WWW” in the Dreamhost panel domain options, all the pages on our site show “Error 310 (net::ERR_TOO_MANY_REDIRECTS).”

This is apparently a known issue, as it’s mentioned in this DH support wiki post: http://wiki.dreamhost.com/Removing_the_%22www%22_from_your_domain. But that post doesn’t explain how to remove the www. from an existing Wordpress site without getting the redirect problem. Can anyone help?


#2

For an slightly different reason I was having a problem that resulted in that error, but only on safari and only on some devices. The solution in my case was to clear the safari cache manually, and after realizing that also had a friend test. It appears that the safari cache was the problem. Hope that helps.


#3

We found the solution. In case anyone has a similar question in the future, you have to not only change the settings in the Dreamhost domain options, but also remove the “www” from the “Wordpress address” and “site address” fields in the Wordpress General settings.