Remote MySQL access


#1

This issue popped up spontaneously overnight, everything was working fine for the past several weeks.

I had a MySQL database outage this morning, and once I was back up and online, I was no longer to access the MySQL database from one of my hosts. I have all of the hosts that specifically need access granted in the mysql/users section of the webpanel (I had to do so to grant access initially). Even though nothing has changed, I all of a sudden cannot gain access from the single host. There are 5 hosts that are configured for access, and this is the only one that is having issues.

I tested my connection to the server using ping and tracert, and everything there was fine. But when I run
mysql -u username -ppassword -h hostname databasename
It doesn’t connect, it just sits there. I copied and pasted the command to another machine that has access, and it works fine there.

I also tried modifying and then resaving the list of allowed hosts in the MySQL settings, but it had no effect. I have already put in a support ticket, but it’s been sitting there all day, and I was wondering if any of you had any ideas


#2

My initial thought is that it’s PC specific - perhaps a program or firewall, etc. denying access.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost