Reminder for 1 year+ wordpress sites

Check your domain (go into panel and edit your domain and each subdomain) for the default PHP, you want to be current which is 5.3. This needs to be changed manually. I had a site significantly speed up when upgraded.

-Bill

Thanks for the reminder. I thought for sure I was already on 5.3. Glad I checked.

Also try out PageSpeed. I’ve been getting phenomenal results from it.