Relay Access Denied

Can anyone help me with this error. Everytime I try to send an email (Pegasus Mail 4.01 is my mailer) using an identity hosted by Dreamhost I get this response. My ISP is Cox and with my last hosting service I had no problem sending emails from my hosted addresses instead of my Cox address.

------------------pasted error message ----------------
Delivery has failed on the enclosed message for the following
reasons reported either by the mail delivery system on the mail
relay host or by the local TCP/IP transport module:

554 Recipient address rejected: Relay access denied
-------------end pasted error message-------


It’s possible that Cox has changed their policies. Are you using their SMTP server as your outgoing mail server?

If your ISP doesn’t block port 25, you can also use our mail server for outgoing mail, provided you use SMTP authentication in your client.

We may eventually offer SMTP on port 587 (the message submission port) to allow customers whose ISPs block outgoing connections to port 25 to send mail.

Cox doesn’t block port 25 and this error isn’t caused by that anyway. I’ve got my outgoing mail server set to and I have it polling first to authenticate.

The information I’ve found regarding this error is:

Relay Access Denied

Another domain error that can be due to either the sender’s or recipient’s domain is a relay access denied error:

554 Recipient Address rejected:
Relay access denied

Another reason for receiving this error is the possiblity that a domain has recently changed hosts, and while the change has taken place, the new domain record has not yet propagated fully, and your message reached the old hosting company which no longer accepts mail for the leaving domain. If you receive this error, try resending your message twenty-four hours later.

So my concern is that for some reason email I send out is being bounced because it’s trying to go through XO Hosting’s mail server even though I’ve updated all my settings to have it go through Is there any way I can check this? Could the DNS update not have effected the mail server?

interesting developments

Ok so here’s the lastest. If I send email from a dreamhost hosted mailbox to another the dreamhost email hosted address everything works fine. Example I sent an email from to and no problems. The relay error is occuring when I try to send email from a address to an email outside the system, like a or address. Doesn’t that point to the issue being somewhere in the dreamhost system?

I can see my email client checking mail, then sending it, but the moment it sends it I get the return mail with the error. And like I said this is only for email addressed outside of


Ok now I’m eating crow. After much frustration I called Cox and they said they do block port 25. So I assume my ability to send email to and from addresses goes around this issue, but I’m not able to send email that’s going to be relayed through DO I understand that correctly?

So now my question is how do I send email that will appear to be coming from y hosted accounts> IS my only real option to use webmail? Which isn’t a bad option anyway, just not as convenient. Is there an option that will allow me to continue to use Pegasus? Would that be to simply have my Reply-To address set as my hosted address though the From would have to be my Cox address.

Wil, you and I have discussed this privately in the past.

Now that you have the new mail server in place, is there any chance of getting the alternate port SMTP access bumped higher up on the “to-do” list? I really think it’s becoming an issue for more and more people.

sure. it’s actually fairly simple to do.

i’m leaving for vacation on saturday; i’ll try to get to it before then, but if not, please shoot me a friendly reminder after the 21 and bug me about it.

port 587 should now work. i can’t get any of the GUI mail clients on my machine to specify a different port than 25 for SMTP, but it should work.

i’ll try to get someone to test that here, but let me know if it works for you (i’m not going to announce it formally yet).

Works for me. (I use Pegasus, so setting the port is a snap.)

Thanks, Wil.

I can’t get it to work but then I’ve never had Outlook 2000 (which does let me specify stmp port mumber - Tools|Accounts|Properties|Advanced) set-up to use dh stmp before, AND I can’t even get MicroSh*t Notwork stmp to work though their own servers. They make me appricate DreamHost support more everytime I contact them. :slight_smile: