Register Globals

apps

#1

Hi,

I have tried to make my custom php.ini by following the instructions given at http://wiki.dreamhost.com/PHP.ini. But I am getting "Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@malikplaza.com and inform them of the time the error occurred, and anything you might have done that may have caused the error"

Is there anyone who can help?

My .htaccess file looks like below:

$Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $

This is used with Apache WebServers

For this to work, you must include the parameter ‘Options’ to

the AllowOverride configuration

Example:

<Directory “/usr/local/apache/htdocs”>

AllowOverride Options

‘All’ with also work. (This configuration is in the

apache/conf/httpd.conf file)

The following makes adjustments to the SSL protocol for Internet

Explorer browsers

#

SetEnvIf User-Agent “.MSIE.” \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

#

If Search Engine Friendly URLs do not work, try enabling the

following Apache configuration parameter

AcceptPathInfo On

Fix certain PHP values

(commented out by default to prevent errors occuring on certain

servers)

php_value session.use_trans_sid 0

php_value register_globals 0

Options +ExecCGI
AddHandler php5-cgi .php
Action php-cgi /cgi-bin/php-wrapper.fcgi
Action php5-cgi /cgi-bin/php-wrapper.fcgi

I have given the correct rights to cgi bin folder and files as well. cgi bin has following files:

dispatch.cgi
dispatch.fcgi
php-wrapper.fcgi and php.ini

What more do I need to do?

Regards


#2

Take out your edits and use an auto-installer (link below).

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost