Register_globals is on?


#1

hi, i was installing Joomla and it informed me that RG and RGEmulation were both on. Thought this was odd so checked the Wiki, and it confirms that RG should be off by default. I ran an info.php and it confirms that RG is on… any reason for this? Anyone else having this or did my PHP install get run with the incorrect flags or something?


#2

It means you are running PHP4. If you login to the Control Panel and go into the Manage Domains section, you will be able to edit your domain to use PHP5. Joomla! may give you a warning message about magic quotes that you can safely ignore.


si-blog | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


#3

ah good stuff, cheers. for some reason i presumed DH defaulted to 5.xx these days, not sure why!

Is the RGemulation warning its throwing up anything to be worried about? I need to look thru the joomla options and see if there’s a way of turning off these frankly annoying warning boxes!

Thanks


#4

The RGEmulation issue is easily addressed. Just edit your globals.php file, and change the variable assignment as indicated in the coments. :wink:

–rlparker