Redirects and Google

Hi All,
I have around 8 similar domain names, i.e.,, .net etc.

I want the to be the main domain name that people get redirected too, so that if they type they end up at .com.

There are various ways of doing this via the dreamhost control panel, mirroring, redirects etc and having tried a combination of both i cant find one that google plays ball with.

For example, when i set all sites to mirror if i type in mydomainname into google, it comes up with

So i thought, ok, lets try redirects, so i redirected mydomainname. to and it comes up (eventually) with

Basically, anything BUT

Any ideas what im doing wrong?

Did you do a 301 (permanent) redirect? It may take some time for google to update the information though.

$50 off and 3 free domains with code: [color=#CC0000]DH3[/color] Sign Up NOW or More Codes Here

Mirroring is bad as far as Google is concerned. A Redirect generates a 301, which Google likes.


try visiting your .net domain (or something you expect to redirect to .com) with firefox while you have the live http headers extension installed with its window up. then you can see the responses from the server telling the browser to load a different url instead.

track7 - my dream-hosted site

i should add that you want to set the .com as fully hosted and the others as redirects to the .com in dreamhost’s panel to make sure the .com shows up in the location bar and google won’t index the others and penalize you for duplicate content. it sounds like you already did this but it’s ending up at instead of .com, which is why i suggested looking at the server responses.

track7 - my dream-hosted site

[quote=“patricktan, post:2, topic:52722”]
Did you do a 301 (permanent) redirect? It may take some time for google to update the information though.[/quote]
Can we do this in a .htaccess file in root directory on DH? I tried that because I thought it would work right away (putting an index.html with meta-refresh worked right away) and isn’t the .htaccess the first thing that’s looked for? /me has just enough understanding to be confusilated …

Use the “redirect” option and have canonical meta tags.