Ready to switch DNS and go live

So I currently have my domain hosted by Hostway. I have developed a new version here using a mirror site. I’m ready to move from the domain to here on Dreamhost. I’ve downloaded and installed Velvet Blues url updater. So my understanding is that I only need do the following:

  1. go to the registrar of my domain name and change the DNS names to:

  2. After the DNS change has propagated log into and run Velvet Blues to update the URLs for my content, attachments, whatever.

Is that it? Sounds too easy to me, so I’m guessing there’s a “gotcha” hiding somewhere!


That should do it! Just in case you need it:

What about changing the urls in the General Settings page - do I need to change those, and when to change those - before the DNS change propagates, or after?

Ah, so it sounds like a WordPress site? You may not need the URL updater. If you currently have fully hosted, and mirroring it, you should be able to just change the URLs in General Settings back to now. If you’re using a custom theme with a lot of options, you may also want to make sure that the name isn’t still saved anywhere in the theme/menu settings. Once the main URLs have been adjusted, you should be good to go in pointing the nameservers to ours and making it live.

Velvet Blues url updater works nicely. Sometimes after updating the general settings URL there will still be image links and such that do not get updated…Velvet Blues url updater finds all those and updates them for you, and takes all of 30 seconds.

Just back up your files and database first before you do anything so you have a point to go back to if you make a mistake.

Just an update on this. I followed the directions, went to my registrar ( and entered the three Dreamhost DNS names in place of my previous web host (Hostway’s) DNSs, did the same in the user control panel at Hostway (not sure that was necessary but was led to understand that that change might occur before the actual DNS changes propagated?) and an hour later my new website was live! Went to “Settings>General Settings” and updated “Wordpress Address” and “Site Address” and everything works perfectly! Thanks for all the help!