Raptor Install Problems...Please Help

apps

#1

Hello I just installed Raptor by zeroquest.com on my shared hosting account. The installation process went smooth, but when loading my admin panel I get the following errors at the top of my screen:

Warning: fgets(): supplied argument is not a valid stream resource in /home/.ari/radiantx/radiantx.com/raptor/index.php on line 322

Warning: fopen(): URL file-access is disabled in the server configuration in /home/.ari/radiantx/radiantx.com/raptor/index.php on line 180

Warning: fopen(http://www.zeroquest.com/auto-trade.php?d=&p=&m=wm): failed to open stream: no suitable wrapper could be found in /home/.ari/radiantx/radiantx.com/raptor/index.php on line 180

I have no idea what they mean or how to fix this. Any suggestions or fixes would be appreciated.

-radiantx


#2

If I’m looking at this right, the problem is that Dreamhost doesn’t allow the url fopen function. The script that you are running is trying to use this function, can’t and then throws the error.

As far as fixing it, I’m not positive, but you’ll probably need to change the code to use cURL instead. The dreamhost wiki has more information on this, http://wiki.dreamhost.com/index.php/Allow_url_fopen


#3

This script is using URL fopen, which has been disableed on here for security reasons. You’ll have to contact the coding to use curl instead. Alternativly you could complish your own copy of php and allow url fopen. Both topis are covered in the wiki.

Allow url fopen

installing php5

Custom Compile php4

Good luck.

-Matttail


#4

same time post… cool


#5

Ive installed Raptor on about 5 diff hosts, and its always been cake. For some reason DreamHost is giving me all kinds of funky errors. The script writer has promised to fix the first problem, but now I have another:

Warning: Unknown(): URL file-access is disabled in the server configuration in /home/.ari/username/domain.com/index.php(238) : eval()'d code on line 152

What does this mean, something else the server doesn’t allow? Your suggestions/solutions all sound great but are over my head. I’ll pay someone to do it for me, my icq is 162022652. This is getting ridiculous.


#6

This is not a new problem, you’re getting exactly the same error as before. The links I posted above will be your best bet. If your script author is going to rewrite the script for youto use curl instead of Fopen, then just wait for that revision and you’ll be good to do.

-Matttail


#7

I cant wait a few weeks for him to edit an expensive commercial script just for me.

I need to figure out how to compile my own PHP4 to allow this. Im looking at the code on http://wiki.dreamhost.com/index.php/Custom_compile_PHP_4

I need to be able to allow this:

<?php include("http://example.com/includes/example_include.php"); ?> with example.com being an external site not belonging to me.

What needs to be edited ? Sorry, its all greek to me.


#8

OK, I’m not sure where you are in this process, but you need to follow the instructios in the wiki first. Just go through the standard install just the way it says. Add thoes lines to a htaccess file in the example.com folder. Once you’re done with thoes instructions, you’ll be using your own version of php4 instead of the default one on your server.

Now you’ll need to edit the php.ini file. That should be in the php directory (in your home dir) so you’d type something like:
nano -w /php/php.ini
Then you can press ctrl-w to bring up a search, and type in fopen. Turn that value on. Press ctrl-o to save the file, and ctrl-x to quit. Now your script should work.

This should work for you, however having never done it myself I might be wrong.

-Matttail


#9

Ok, I think Im almost there. I downloaded/installed Putty for Windows, enabled ssh for my account. I followed the directions in the wiki and during the installation of the new php in the ssh screen, it keeps timing out at the http://www.zlib.net/zlib-1.2.2.tar.gaz. Says, failed: Connection timed out. Retrying. And it cycles. I closed the SSH session, found an updated link for zlib (.org) that works. I restarted the process by adding the new zlib.org address to the install script, but for some reason during the installation it continues to come up as .net and stalls. Im thinking its trying to finish the original installation. How do I cancel it and start from scratch? What do you suggest?