Random blank pages with javascripts errors (W3 minify issue?)

wordpress

#1

Hi,
So my website (https://www.airmovie.fr) is kind of working well (especially no issues on Firefox), but when I load it in Chrome or Safari, I get randomly a blank page.
Actually the site loads (I can see the source code) but it is mostly covered by a blank layer.

To recreate the issue, I type http:// instead of https or https:// without www, etc. and I randomly get the blank page. I am a beginner so I really don’t know why it happens so randomly…

When the issue happens, the Safari inspector gives me a few errors with JS files :
WPForm : ReferenceError: Can’t find variable: jQuery
imagesLoaded : TypeError: undefined is not an object (evaluating ‘e.each’)
Magnific Popup : TypeError: $ is not a function. (In ‘$(window)’, ‘$’ is undefined)

Those 3 js files are in the folder /wp-content/cache/minify/

So I guessed maybe the problem was coming from Minify and I tried disabling it in W3 Total Cache. But when I did, the files were deleted and I got 404 errors for my js files because wordpress still wanted to use their old path (/cache/minify/…) I thought W3 total cache would revert the javascript…
After re-enabling Minify in W3, it recreated new js files and the site is now “working” again. But with this random issue.

What do you think I should do? If I could just find why I get these random errors, I would be ok not to touch anything…

Thanks a lot in advance for your help!!!
[hr]
Ok,
So an update :

I disabled Minify in W3 and Enabled it on Cloudflare. As a result, I see no errors. My js files appear again. Fingers crossed (and what would we do without Cloudlfare??)