Rake Migrate Issue?

software development

#1

I am trying to run rake migrate in the config area on my database.yml file. I have the database.yml file staing the port, host all correctly I belive. I also have the enviorment.rb correctly using the production enviorment. I have created these databases in phpmyadmin. Error Message is Below…

EX.
development:
adapter: mysql
database: riot_development
username: #######
password: #######
host: mysql.i-riot.org
port: 3306

test:
adapter: mysql
database: riot_test
username: #######
password: #######
host: mysql.i-riot.org
port: 3306

production:
adapter: mysql
database: riot_production
username: #######
password: #######
host: mysql.i-riot.org
port: 3306

WHEN I RUN RAKE MIGRATE I RECIEVE THE FOLLOWING ERROR…

rake aborted!
'arse error on line 5, col 2: ` host: mysql.i-riot.org

(See full trace by running task with --trace)
[blowpop]$ rake migrate --trace
(in /home/.frowsy/#######/i-riot.org)
** Invoke migrate (first_time)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
‘arse error on line 5, col 2: host: mysql.i-riot.org /usr/lib/ruby/1.8/yaml.rb:119:inload’
/usr/lib/ruby/1.8/yaml.rb:119:in load' /home/.frowsy/#######/i-riot.org/config/../vendor/rails/railties/lib/initializer.rb:459:indatabase_configuration’
/home/.frowsy/#######/i-riot.org/config/…/vendor/rails/railties/lib/initializer.rb:181:in initialize_database' /home/.frowsy/#######/i-riot.org/config/../vendor/rails/railties/lib/initializer.rb:84:inprocess’
/home/.frowsy/#######/i-riot.org/config/…/vendor/rails/railties/lib/initializer.rb:42:in send' /home/.frowsy/#######/i-riot.org/config/../vendor/rails/railties/lib/initializer.rb:42:inrun’
/home/.frowsy/#######/i-riot.org/config/…/config/environment.rb:10
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:in require__' /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire’
/home/.frowsy/#######/i-riot.org/config/…/vendor/rails/railties/lib/tasks/misc.rake:3
/home/.frowsy/#######/i-riot.org/config/…/vendor/rails/railties/lib/tasks/misc.rake:2:in call' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:inexecute’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in each' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:inexecute’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:357:in invoke' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:insynchronize’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in invoke' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:364:ininvoke_prerequisites’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:363:in each' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:insend’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:in each' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:363:ininvoke_prerequisites’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:356:in invoke' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:insynchronize’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in invoke' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:364:ininvoke_prerequisites’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:363:in each' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:insend’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:in each' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:363:ininvoke_prerequisites’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:356:in invoke' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:insynchronize’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in invoke' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:inrun’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in each' /usr/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:inrun’
/usr/lib/ruby/gems/1.8/gems/rake-0.7.1/bin/rake:7
/usr/bin/rake:18:in `load’
/usr/bin/rake:18