Rails startup trouble?

I found several people with a similar problem - strange fcgi errors (below) in the apache error log when a rails app is starting up. I get lots of these errors then after 20 minutes or so the app finally starts. I couldn’t find any good explanations or fixes however… anyone know?

[Sun Jul 9 12:17:48 2006] [error] [client 216.15.56.201] FastCGI: comm with (dynamic) server “/home/chris24e/birdlogger.firati.com/public/dis
patch.fcgi” aborted: (first read) idle timeout (120 sec)
[Sun Jul 9 12:17:48 2006] [error] [client 216.15.56.201] FastCGI: incomplete headers (0 bytes) received from server “/home/chris24e/birdlogge
r.firati.com/public/dispatch.fcgi

Thanks!

Chris Eagan

Did you ever solve this problem? I’m having the same issue…

No. I even deployed a new app last week and the exact same thing happened. On the bright side it did start eventually.

If we can’t do anything (we are in the client side), we still have an option.

contact DH support.

Although it takes a long time to receive reply, there at least a hope.

Save [color=#CC0000]$97[/color] (max discount) on dreamhost by using promo code: [color=#CC0000]97CRAZY[/color].

Hey,

I’m also having problems with FCGI, which is showing the generic error for my website;

Application error
Rails application failed to start properly

My URL is; http://blog.hanabi.co.uk/

I contacted support and they sent me the following:

Debugging your rails application is beyong our scope of support. Your fastcgi.crash.logs contained the following errors. I can suggest that
you consult our member forum http://discussion.dreamhost.com. Often times you can receive tips from users who have encountered similar problems. If you have any additional questions, please let us know.

[08/Jan/2007:15:21:23 :: 4602] Dispatcher failed to catch: private
method
`split’ called for nil:NilClass (NoMethodError)

/usr/lib/ruby/1.8/cgi.rb:897:in `parse’

…/config/…/vendor/rails/actionpack/lib/action_controller/cgi_ext/raw_po
st_data_fix.rb:45:in `initialize_query’

/usr/lib/ruby/1.8/cgi.rb:2274:in `initialize’

/usr/lib/ruby/1.8/fcgi.rb:594:in `new’

/usr/lib/ruby/1.8/fcgi.rb:594:in `each_cgi’

…/config/…/vendor/rails/railties/lib/fcgi_handler.rb:141:in
`process_each_request!’

…/config/…/vendor/rails/railties/lib/fcgi_handler.rb:55:in
`process!’

…/config/…/vendor/rails/railties/lib/fcgi_handler.rb:25:in
`process!’

./dispatch.fcgi:24

killed by this error

So it looks like this is a more general problem, but isn’t going to be fixed by DH. :frowning:

Does anyone have any new leads on these problems?