Rails. i give up

software development

#1

I’ve been banging my head against the wall for two weeks trying to get even the most skeletal rails application running on dreamhost. I can’t. I give up. I don’t care if you call me a troll, or a newbie, or whatever. Has anyone gotten a rails application to work here? If you have, can I describe my setup and maybe you can tell me what i’m doing wrong?
I’m using the latest version of Rails (I updated today), I have my environment variable set to production, I’ve doublechecked my database info three times, I’ve tried redirecting routes.rb to a scaffold (a SCAFFOLD, for Pete’s sake!) and it still doesn’t work. I tried running it in development mode. Nothing. THE GOGGLES-THEY DO NOTHING!
The only progress I seem to have made is graduating from a “Rails failed to start properly” error to "Application Error (Rails)"
Has anyone gotten past this?


#2

I have an app running at http://fanmail.nerdbucket.com.

But it only works sometimes. I have the ever-elusive intermittent 500 errors that have no error log data…

So I’m not sure I can help you. Although in my case, it at least is running more often than not, so who knows, maybe I can help. My first suggestion would be to take it out of production mode and see if you get any useful error messages.


#3

Thanks man. Actually, the issue turned out to be my table names, though I had to go digging through the error logs to figure that out. It’s working ok now.