Rails Error

software development

#1

I just tried to set up a simple Ruby on Rails site (on the otto.dreamhost.com server), and when trying to use the rails ‘generate’ script, I get this error:

[otto]$ ruby script/generate controller MyTest
/usr/local/lib/site_ruby/1.8/rubygems.rb:144:in activate': can't activate activesupport (= 1.1.1), already activated activesupport-1.2.1] (Gem::Exception) from /usr/local/lib/site_ruby/1.8/rubygems.rb:162:inactivate’
from /usr/local/lib/site_ruby/1.8/rubygems.rb:161:in each' from /usr/local/lib/site_ruby/1.8/rubygems.rb:161:inactivate’
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:23:in require' from /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.1/lib/active_support/dependencies.rb:213:inrequire’
from ./script/…/config/environment.rb:51
from script/generate:2:in `require’
from script/generate:2

I googled for this error, and it seems to be a pretty widespread problem, does anyone know a workaround?

Thanks in advance,
Tom


#2

Seems to work today. Weird.