Rails down... again


#1

DH upgraded Rails to 1.1.5 yesterday and 1.1.6 today. After yesterday’s upgrade, everything was fine. After today’s, all hell broke loose.

All my Rails sites are dead – in fact, no dispatch.fcgi processes appear to be running.

Has anyone had similar problems with their Rails sites since today’s upgrade?

Thanks,
Rick


#2

My rails site crashed late on Thursday. I have the same problem of being unable to restart ruby and dispatch.fcgi processes.

Chris


#3

I know nothing about rails and never messed with it, so I don’t know if this helps… but another host I use released this when they did a recent upgrade:

[quote]Please be aware that Typo versions prior to 4.0.0 are not compatible with
Rails 1.1.x and will break during this upgrade (unless you have frozen your
Rails gems into your vendor directory). Even if you have previously frozen
your gems, it is highly recommended that you take the time to upgrade to
Typo 4.0 and Rails 1.1.5 to ensure your site’s security. Everyone running
Typo tha is not current trunk or stable version 4.0 must upgrade to ensure
their site’s security in light of this rails security issue.[/quote]
So, maybe there are certain things that break on the upgrade? If Ruby has a changelog available, it might be something you could read through and see if you need to change anything you’re doing.

I don’t know how many people are using it here, but if it’s more than a handful, there should be more people jumping in on this thread if it’s a system-wide problem.

Otherwise, I would guess that it’s just certain scripts breaking.

Or I could be way off, which would be explained in the first sentence of this post. :wink:


:stuck_out_tongue: Save up to $96 at Dreamhost with 96DOLLARSOFF promo code (I get $1).
Or save $97 with TAKESEILERSCASH.


#4

I had the same problem and didn’t get any responses from DH Support. I changed line 8 of environment.rb to look for the new version of Rails and it works (almost) like normal now.

RAILS_GEM_VERSION = ‘1.1.6’

This solved the problem of starting up. But, routing has failed as my login_engine no longer works.

Ugh.


#5

I don’t know if this helps but after the upgrade I had to “rails myapp” again and overwrite almost everything.

digitalrundown.com


#6

@brmurray:
Just tried changing environment.rb to use 1.1.6 with no luck. Still no dispatchers.


#7

@seiler:

Thanks, but that’s not the problem. :slight_smile:

If it was, it would be complaining loudly. (Rails is good like that.) The dispatchers aren’t even running, so Rails doesn’t have a chance to complain.


#8

@brmurray:

I take that back. It worked. The site is up and running again – and in my case, the whole site is working fine.

Thanks a million for the tip!

Maybe someone should tell DH support so they know how to answer these questions.


#9

@wjd:

I bet that works because it overwrites environment.rb with the correct Rails gem version.


#10

Yeah I sent in the most urgent help ticket and they still haven’t responded after 24 hours.

Thanks for the fix though, my site is up and running again!


#11

My pleasure, Rick.

I sent them another ticket with low piority this morning telling them about the fix. I still haven’t heard back on that ticket I filed yesterday (also highest priority…first time i’ve used it)

Maybe they automatically Trash the “OMG Pople are Dying” selection?? Haha.

Login_engine and routing are still dead. I get a 404 for anything that is using engines. They must really being having a hell of a time with something if their responses are THIS slow. I don’t think it’s ever been this bad.


#12

Did you get anywhere with this? I can only get static pages (index.html) served back. dispatch.fcgi never seems to start up. I put a ticket in 24 hours ago and am still waiting for a human to reply. Any feedback you can share would be appreciated. Thanks.


#13

Yes, actually – updating environment.rb to reflect the latest version number worked, although there was a slight delay.


#14

Found a solution to this, I think. It appears that deleting all the old session files in tmp/session fixed what was broken.