Rails app works on localhost but not on remote!

software development

#1

So…I installed Rails on my hosting account, and it gave me the index page that says congrats, set up your default routes and rename/remove this page, blah blah blah…cool!

Did the same thing locally…again, success…

So I threw together an intro page and configured routes.rb, poof! Got my intro page on localhost!

So I tried the exact same thing, exact same route, EVERYTHING…remotely, but now…I just get a listing of the contents of the “public/” folder…

What should I be looking out for???


#2

By exact, you mean you manually did the same things or you actually copied the files? If the former, you did something different. There’s a typo somewhere. If the later and you are developing on Windows, there may be differences such as using backslashes (on Windows) and forwardslashes (on the server).


#3

I’m using a Mac, actually…I copied the files. When that didn’t work, I actually regenerated the controllers and such and typed manually. Same problem.


#4

Okay, basically, I guess what I’m saying is…Rails is 100% ignoring routes.rb. I even tried renaming it just to see if it would error out; it didn’t.