Rails 3.1, Passenger and Rack

software development

#1

Hi there,

I’m deploying a simple web app made with Rails 3.1, using Passenger.
As soon as I moved all my files to server, I tried to access the app in browser (ads.flipstudio.net/admin) and I got the following error:

You have already activated rack 1.2.1, but your Gemfile requires rack 1.3.5. Consider using bundle exec.

After that, I did what any developer would do: googled a lot to find a solution.
I found out people is getting trouble with the same situation and I tried using every single sugestion. Since adjust the rails code to bundle as deployment and nothing seems to work.

As long as many people is getting the same problem, does somebody now something I can do to solve it?

Thanks in advance,
Vieira


#2

Why no one has answered this question. Is there a solution for this? I am really stuck on this problem. And have no Idea how to solve it, I have googled and no answers.

Thanks

-Martin


#3

I have very little Rails knowledge, but have you read this thread: http://discussion.dreamhost.com/thread-131287.html it seems very similar to me.