Quick Quetsion, Help Appreciated


#1

I am having the follwing issues:

  1. I cannot get the server to recognize changes I try to make to PHP behavior via .htaccess.

  2. I cannot use URL’s of the format http://www.united-clan.com/profiles/index.php/137, in conjunction with the code

CODE:
$pathdata = explode ("/", $_SERVER[‘PATH_INFO’]);

. I get a “No input file specified” message.

Any help is awesome! Thanks!


#2

mod_rewrite is not enabled on your server. You can add following rule in your .htaccess to make it work for your account :-

Options +FollowSymlinks
RewriteEngine on

Outsourced Hosting support and Server Management


#3
  1. PHP configuration via php_flag or php_value in .htaccess only works when using mod_php, not PHP-CGI, which is the default at Dreamhost. You may be able to make your changes using ini_set().

  2. Since you’re just dumping the URI path into an array, you can change $_SERVER[‘PATH_INFO’] to $_SERVER[‘REQUEST_URI’]. Using your example, 137 will be found in $pathdata[3].

This has nothing to do with symlinks or mod_rewrite (which, to the best of my knowledge, is enabled by default on all DH shared servers).


If you want useful replies, ask smart questions.