Putty SSH configuration


#1

I know it’s not DH’s product, but I’m getting nowhere with Putty 0.58 on my XP. I just downloaded it, fired it up, but all I ever get is a Network error. The log looks like:
2005-11-07 15:00:04 Looking up host "kiki.dreamhost.com"
2005-11-07 15:00:04 Connecting to 66.33.219.5 port 22
2005-11-07 15:00:04 Failed to connect to 66.33.219.5: Network error: Connection refused
2005-11-07 15:00:04 Network error: Connection refused

Now I have shell access enabled for my account, and telnet to DH often. Even the telnet side of Putty works for me. Do you suppose my port 22 is blocked at the enterprise firewall or the Windows firewall? ssh to dreamhost works just fine from my UNIX box. There’s something very basic about Putty that I’m not seeing. The KB tells me that SSH1 has been phased out, and to use SSH2.

I then followed the applicable instructions at https://www.daml.org/lab/puttycvs.html and generated a private key, but still was unable to get past this network error.


#2

I have no trouble with PuTTY 0.58 on Windows XP (Professional). In fact, I was using it about an hour ago with no difficulty. I imagine there is some non-DreamHost issue giving you problems. I don’t do any special configuration, like you have. I just whack in my domain name and feed it with a username and password when asked.


Simon Jessey
Keystone Websites | si-blog


#3

I’ve got a Putty 0.58 session open on XP as I type this. Didn’t do anything fancy with its settings. I have SSH ticked. Using port 22. Have you enabled SSH access, with the BASH option, under the Users tab in the DH admin panel?


#4

Sure, I have shell access enabled. I didn’t have bash as the default shell. I changed that but that hasn’t made any difference. However, I like starting out in bash. Like I said, Putty lets me telnet to DH and I can ssh in from my UNIX box with command line ssh.

I tried a couple differnt ports with Putty ssh, but didn’t get a connection at all:
2005-11-09 09:10:02 Looking up host "kiki.dreamhost.com"
2005-11-09 09:10:02 Connecting to 66.33.219.5 port 23