PuTTY SSH and MYSQL

software development

#1

I have been reading the DH Wiki regarding the subjects in the well, subject, here http://wiki.dreamhost.com/index.php/MySQL however I am still having some issues.

Being an outright n00b at using PuTTY and working within shell accounts (my last host didn’t support them) I understand that i should login to my account via SSH using the code: “ssh -l yourlogin www.yourdomain.com” but what I don’t understand is what is the format for “yourlogin”. Is it just my username, or my username and password (in either case, I know it’s the one I set up specifically with shell access) and is it simply the username and/or password or do I need any special delimiters, like -u and-p?

Currently when I try to log in using the above format, I get the message in PuTTY “Using Keyboard-interactive authentication. Password:” however I cannot enter a password, so I only get an access denied error.

I am not quite sure what to do, so any help is appreciated and I will provide as much more information is requested (within reason).

Thanks


#2

I have forgotten in the past to remind users who have come from a host where shell access was not available to remember to enable shell access for their user before attempting to use the shell. None of this will work if you do not have shell access enabled for your user.

Don’t forget to also review http://wiki.dreamhost.com/index.php/SSH, as there is also considerable information there that you will probably find relevant.

From the Wiki article on the shell (see above), the format of “yourlogin” is:

ssh username@your.domain.com

I’m not sure what you mean by “I cannot enter a password” (note that you will not see the entry of any characters on your screen when you enter a password - the screen wil not change at all as you type the password). It could be that you are typing the correct passord, but you “login” is incorrect.

Another consideration is that, since you have tried this several times without success, the following excerpt from that wiki article might be relevant:

Server unexpectedly closed network connection

If you get this error when attempting to SSH (or SFTP/SCP), this can mean your IP has been blocked due to an excessive number of failed login attempts. You will get no notice that this has happened. Contact support and they will remove the block and whitelist your IP address. If you don’t know your IP, visit http://www.whatismyipaddress.com.

–rlparker


#3

Thanks for the help rlparker, I am not quite straight yet though, I am sure there is some glaring oversight I am making, but after reading the wikis on both SSH and MySQL I have yet to be able to access my shell with PuTTY. Just to be sure, following are the pertinent settings I have set within PuTTY:

The domain I want to access is test.roberthenrylowe.com so,

Under session, I have test.roberthenrylowe.com set in the Host Name via port 22 with SSH as the activated Protocol.

Under SSH > Tunnels, I have 3306 set as the source port and test.roberthenrylowe.com:3306 as the destination.

The log in process for me goes as follows using above saved settings:
Open shell window,
See “login as:”,
Type shell enabled username, in this case, robshell, press enter,
See "robshell@test.roberthenrylowe.com’s password:",
enter password,
See “Access Denied”,
Repeat until under desk, crying in fetal position.

I did read through the SSH wiki, and got partway through the passwordless login. I get to “Upload the public key to your Dreamhost home directory. After you’ve generated the key and copied it to the server, you’ll need to import and append the key to authorized_keys with the following command. Use >> instead of > to append to the file instead of overwriting the contents.”

However I do not know where to import the key to so that I can append the file…

Once again, any assistance is very much appreciated.


#4

I’m sorry you are having trouble with all this, so lets start from the simplest possible PuTTy login.

Your PuTTY settings are fine for the host and the port, and leave SSH selected as the protocol.

You might want to put your user name into the settings by selecting “Connection” and entering “robshell” (no quotes) into the “Auto-login username” field

For now, don’t set up tunneling - let’s get connected first. Leave all settings in PuTTY’s config screen for tunnels at their defaults - set only these three things (everyting else is “blank” or “unchecked”):

  1. x display location should say localhost:0,
  2. MIT-Magic-Cookie-1 radio button is checked
  3. Destination is not filled in, and the radio buttons below have only “local” set

You are now set up for the most basic putty use for connecting via ssh.

Now try the login process as described, Remembering that passwords are CaSeSENsiTive.

If you cannot connect this way, something is either wrong with you user/password combination, or something is not right on the Dreamhost end. You should get past this part before you try to set up tunneling or worry about passwordless login :wink: .

While I don’t recommend this for general use, you might try logging into the shell via a plain ol’ telnet program, and see/confirm that your user/password combinatioin is working as expected.

Remember my comments from my previous post about making sure shell access in enabled for user robshell in the Control panel, and realize that repeated failed attempts could have caused Dreamhost to “lock” you out until you contact them.

I suggest you give it a try using these instructions, and if that doesn’t work, it is probably time to call in the DH tech Support guys, as I don’t know what else to suggest.

–rlparker


#5

Thanks rlparker. As I assumed from the beginning, a large part of my problem WAS an oversight on my part, I was using the wrong combination of domains for the dbdomain and dreamhost domain in the various settings pages in PuTTY, I figured it out after rereading the wikis and following a few of the links in those pages, I can now happily connect to my shell account via SSH and even manage my MySQL accounts, thanks again!


#6

You’re welcome! I’m glad you got it sorted, though I wish I could have been of more help. I guess the “upside” is that yhou have learned a lot in the process, eh? :wink:

–rlparker