Public objects are served with connection:close?

dreamobjects

#1

Is closing the connection after each static object a wise choice?

Amazon uses keep-alive for good reason.

Also, what is with using Apache to serve, certainly that is not going to scale to the levels you need?

If you are using apache though, you could set keep-alive with a one or two second timeout. That will give it a chance to reuse the connection if there is another object on a page.


#2

No, probably not. Ceph’s RADOS Gateway manages the S3 and Swift API connection and it runs in Apache. We are doing some work now to enable keepalives to the load balancers. This should help with upload speeds and promote better scaling on the gateways without killing Apache with open keepalives.


#3

That would be great! Right now, all website performance analysis tools I’m using to test content served from DreamObjects complain a lot about lack of keep-alive.


#4

Just remembered to check my test object and to my pleasant surprise, I see keep-alive now.

Not sure when that changed but keep up the good work dreamhost.

Update: weird, I sometimes see it, sometimes not.

Are there some servers that have newer software than others?

Ah okay - this is my fault, one of my testing tools was not sending “keep-alive” in the request headers.

But it’s definitely been fixed from what it was last month.