PS no sendmail


#1

Hi all,

I’m moving some of my shared hosting drupal sites to private servers and I came across an email error which was very helpful: “Error sending email.”

When I SSH into the private server, I can’t run mail -s… like I can on the shared hosts, which leads me to wonder if sendmail is even installed by default.

Can anyone shed some light? If I need to install sendmail/postfix/exim (etc), should I point that to a dreamhost smtp smart host for outgoing email, or just use direct SMTP? Another forum post I read said that PS accounts allow direct SMTP.

Any help or thoughts would be appreciated. Thanks!


#2

Postfix should be installed by default have you tried using the sendmail or /usr/sbin/sendmail commands?


#3

You are right, it is installed.

I created a PHP page of phpinfo(), and saw that mail is invoking “/usr/sbin/sendmail -t -i”. When I ran that from the command line, I got the following error:

sendmail: fatal: chdir /var/spool/postfix: Permission denied

It appears my user didn’t have rights to go to /var/spool, it was granted to root:telnetd.

I ended up solving the issue by adding my web user (the user the web site is running under) to the telnetd group, log out, log in, and lo and behold, I could run /usr/sbin/sendmail.

I sent a test email from PHP, and all worked out great. I don’t know if this was something specific to me and my PS (I didn’t change anything to cause this), but hopefully it helps somebody else down the road.