Proxy throughput with mod_rewrite?


Good afternoon.

I am trying to set up a “proxy throughput” rule using mod_rewrite. My specific intent is to provide access to one of my Gallery2 albums without publishing the actual location of my album.

So I created my directory for anonymous access, something like this:

and then put this in the .htaccess file.

RewriteEngine on
RewriteRule ^.*$ [P]

It doesn’t work. I see the following in my error log:

File does not exist: proxy:

What’s the problem? Does this feature require that a proxy server be running? Or is something else going on?



Taken from Apache module mod_rewrite:

[quote]‘proxy|P’ (force proxy)
This flag forces the substitution part to be internally forced as a proxy request and immediately (i.e., rewriting rule processing stops here) put through the proxy module. You have to make sure that the substitution string is a valid URI (e.g., typically starting with http://hostname) which can be handled by the Apache proxy module. If not you get an error from the proxy module. Use this flag to achieve a more powerful implementation of the ProxyPass directive, to map some remote stuff into the namespace of the local server.

Notice: To use this functionality make sure you have the proxy module compiled into your Apache server program. If you don’t know please check whether mod_proxy.c is part of the httpd -l'' output. If yes, this functionality is available to mod_rewrite. If not, then you first have to rebuild thehttpd’’ program with mod_proxy enabled.[/quote]
To my knowledge, mod_proxy is not installed on DreamHost servers.

Max discount on any plan with promocode SCJESSEYTOTAL


As I suspected. Thanks!

I suppose I could have made my original question a bit less long-winded, given the simple answer. :-o



Correct, it is not installed in the shared environment.

Save [color=#CC0000]$97[/color] on all plans by using promo code: SRVR97. More Here