Problems with ringlink webring script

software development

#1

The machine I’m on just recently got upgraded to perl 5.6. Since then the web ring program I use, called ringlink, doesn’t work. It keeps saying I don’t have a file when it’s there. I’ve tried support but it’s basically become a “sucks to be me” And I can’t find any other scripts out there that will work. Wondering if anyone else is having problems or if they know of another web ring program.


Todd Eddy
vrillusions.com


#2

I’m still on Perl 5.005_3, but could not get Ringlink 2.37 to run without a lot of hassle. They left out a variable in the configuration module as well as hardcoded the scripts to look for language files relative to the script path. Even after fixing those two bugs, the scripts give Interner Server Errors for premature headers. But when I run them from the shell, the output is just fine.

I’d write my own and use MySQL instead…


#3

That’s what I’d figured I would do if this doesn’t work. Although I’ve been having that open_basdir restriction error message a lot lately shrugs shoulders. There are a couple other premade php scripts that when i try I get that open_basdir stuff. But since this is a small ring, I might just sign up at someone else’s site and just use it from there. (plus that way I can see if they can just copy the datafiles over so no one will have to re-register).


Todd Eddy
vrillusions.com