Problems with PHP 5 install script


#1

Hello,

In order to use PDFlib, I attempted to install PHP5 as described here:

http://wiki.dreamhost.com/PHP5_installscript

I copied the script, changed the DOMAIN= line, modified the script’s permissions, and executed it.

It chugged along for a while, and I think a lot of things installed correctly, but it eventually quit saying:

[color=#FF0000] “configure: error: There is something wrong. Please check config.log for more information.”[/color]

I found the offending config.log - you can see its complaints below. Obviously, curl thinks some files are missing, but I don’t know why.

[color=#A9A9A9]php5-source/curl-7.20.1/config.log:conftest.c:15:28: error: ac_nonexistent.h: No such file or directory
php5-source/curl-7.20.1/config.log:conftest.c:15:28: error: ac_nonexistent.h: No such file or directory
php5-source/curl-7.20.1/config.log:conftest.c:43: error: ‘force’ undeclared (first use in this function)
php5-source/curl-7.20.1/config.log:conftest.c:43: error: (Each undeclared identifier is reported only once
php5-source/curl-7.20.1/config.log:conftest.c:43: error: for each function it appears in.)
php5-source/curl-7.20.1/config.log:conftest.c:43: error: expected ‘;’ before ‘compilation’[/color]

Does anybody have a clue what might have gone wrong? Otherwise, I guess I’ll have to dig through Makefiles for six hours before (probably) giving into defeat.


#2

That install script is out of date. Please don’t use it.

PHP 5.3(.5) is available through the Panel, and can easily be customized to load additional extension modules. See http://wiki.dreamhost.com/PHP.ini#PHP_5.3 for details.


#3

Great, thanks Andrew - this looks much more manageable.

Is there a way to test that my phprc file is indeed being parsed? After upgrading my account to PHP 5.3 FastCGI, I added one line to my phprc. It should be loading the PDFLib module now, but phpinfo() shows no PDF section.


#4

The two most likely possibilities are (1) the old PHP configuration is still being used because PHP hasn’t been reloaded yet, and (2) the PDFLib module you added isn’t set up properly.

Both can be solved pretty easily from a command line: the first by forcing a restart with “killall php53.cgi”, and the second by running “/usr/local/php53/bin/php” and seeing if any errors show up.


#5

Thanks - I was able to fix my problem using your advice.

In case others encounter this, I ran second command and it reported:

[color=#FF0000]PHP Warning: PHP Startup: Unable to load dynamic library ‘/home/…/.php/5.3/libpdf_php.so’ - /home/…/.php/5.3/libpdf_php.so: wrong ELF class: ELFCLASS32 in Unknown on line 0[/color]

Using ‘uname -a’, I verified that my server is in fact 64-bit. I downloaded the appropriate library and it now works properly.