Problems with Directory/Path in iweb


#1

Hi, I’m really am new to making websites and are probably just missing one little thing but I made a website using iweb, but I keep getting errors when I try testing out my website, or when I try publishing it.

My guess would be that the directory/path isn’t working… I’ve looked at the wiki part for iweb and I “think” I’m putting everything in right but I might not be doing the right thing either :frowning:

Could somebody give an example of what I should be putting in? Other than the password of course. And is there anywhere I can go to see that info again other than in the email they sent me with my username, pass, server etc.

Thanks for your help!


#2

When I used iWeb, I publish to a folder on my desktop. then FTP the whole thing up to my site. It’s the contents of that folder that you need to upload. You can use Filezilla to upload your site. Don’t just drag that folder from your desktop to your site. In that folder there should be an index.html file. Open the folder and upload the files, including index.html, and subfolders.

I found this link in Google but can’t check it out because I’m behind a firewall:
http://www.tuaw.com/2009/10/26/mac-101-publish-iweb-09-sites-to-ftp/[hr]
Thank goodness for Google cached pages. From the link I sent you:
Server Address: example.com (your domain)
User Name: The FTP user listed for your domain in Manage Domains. This is not your DreamHost panel login and password.
Password: You know…
Directory/Path: example.com (your domain, no slashes)
Protocol: FTP, Port 21

And make sure that your user has FTP enabled. This is done through the DreamHost panel under Manage Users. If they’re allowed to use FTP, there will be a WebFTP link in the right column.


#3

@sdayman: I’m having a similar problem to the earlier post, and thought your reply was interesting. Here’s my twist: I have an existing website, but just started using iWeb. When I publish through iWeb to my existing site, it either does not upload the folder so that it creates a subpage on my main site, or (when I try to change the FTP settings by inserting a forward slash (/) as the directory) tries to overwrite my existing index file. Presumably I do not want to do that, otherwise the new pages will just replace my home page, vs. becoming a subpage. As an example: my current home page is www.calwalkers.com. I am trying to load a new page for which I want the URL to be www.calwalkers.com/YorkshireMoors. Any suggestions? Thank you!

[hr]
@sdayman: followup. I saw something in another thread that I thought might solve my problem, and it did. in the iWeb Site Publishing Settings window, in the field for Directory/Path under FTP Server Settings, I entered my homepage URL followed by a forward slash (/). This did it. Before I just tried entering a / there, and it wanted to overwrite my home page index file. Don’t know why this did not occur to me to begin with! Oh well; thanks for your help in this forum!