Problems Restoring mySQL DB


#1

I created a new mySQL db from within the panel. Then I used phpMyAdmin to restore my db (an exported gzip from another host). When I tried this, I got the following error:

Fatal error: Allowed memory size of 52428800 bytes exhausted (tried to allocate 16174891 bytes) in /usr/local/dh/web/phpmyadmin/libraries/read_dump.lib.php on line 115

Why did I get the error when my filesize was less than the maximum allowed memory size?


#2

I believe this is a known problem with Php my admin not allowing large files to be dumped.

You’ll need to accomplish this through telnet / ssh. Check out this K-base article for more explination.

-Matttail


#3

Thanks. Why doesn’t it allow a 16mb file when is says that the limit is 50mb? Or is the limit not the same as the phpMyAdmin limitation?


#4

I worked around the issue by restoring all but one (9mb) table.


#5

http://www.ozerov.de/bigdump.php

Give it a look. It’s a script you can run to upload large databases right from the FTP and without worrying about phpmyadmin limits.


#6

Or, upload your SQL file to the server

Telnet to your account execute:
mysql -hHOSTNAME -uUSERNAME -pPASSWORD DBNAME <YOURSQLFILE.sql

BAM done.

-Jason

I40.com - Home Page
MP3Mystic - Personal Streaming Music server.
(No longer hosted with Dreamhost)