Problems moving Movable Type to DH

apps

#1

Hi. I’ve just moved my domain to DreamHost … but I made the mistake of canceling service at my old provider before making sure Movable Type was working for me here. In other words, I neglected to follow the instructions I’ve since read on how best to move MT to a different provider.

I was using an older version of MT there – version 2.21. Might anybody be able to offer suggestions? The short of it is that MT does respond but does not recognize my username or the existing database (in which I have three blogs). (My thinking is to try to get 2.21 working again, after which it’ll be worth considering upgrading.)

I’ve done this:

  • Uploaded (in ASCII – except the database files, those in binary) all of my site’s files, including the “mt” directory where MT had been installed.

  • Changed permissions of the *.cgi files to 755

  • Edited the mt.cfg file (changed the DataSource line to the new filesystem path appropriate to DreamHost)

  • Run the mt-check.cgi, and it said that everything (both necessary and optional) is installed

I found documentation (http://www.movabletype.org/docs/mtmanual_troubleshooting.html – see “I changed hosts, and now I can’t log in to Movable Type”) which looks like it might be applicable. I tried to run the “db_upgrade” command as instructed, but apparently that command isn’t available here on DH.

So I tried the suggested “db_dump” and “db_dump185” commands but got errors. “db_dump” results in this output:

db_dump: author.db: unsupported btree version number 8
db_dump: author.db: Invalid argument

“db_dump185” results in this output:

db_dump185: author.db: Invalid argument

Oh – as may be obvious by now, my MT installation uses the Berkeley DB, not MySQL. As for the “db_dump” commands, the docs say that “if the command is successful, you will see a screenful of data. If this also fails, then you will need to contact your hosting provider.”

At this point, I’m not even sure what question to ask the good DH support folks … so here I am, pleading for your help.

I’d be grateful if anybody has suggestions. Thanks.

-John

(By the way, I have also seen wombatnation’s nice http://www.wombatnation.com/misc/installMTDreamHost.html, but I’m trying not to do a scratch installation as yet. So.]