Problems making clamav-0.96

apps

#1

I’ve been making clamav from source on these machines for awhile now, but the new version (0.96) is giving me configuration problems, specifically (at least for the moment) with libltdl. Does this sound familiar to anyone? I must admit that it’s been years since I paid attention to the GNU libraries…

I’m seeing

schweppes:clamav-0.96-> ./configure --prefix=/home/paworama

[configure output not included, but it seemed to work; there were no errors]

schweppes:clamav-0.96-> make
cd . && /bin/sh ./config.status clamav-config.h
config.status: creating clamav-config.h
config.status: clamav-config.h is unchanged
make all-recursive
make[1]: Entering directory /home/.minilotto/paworama/src/clamav-0.96' Making all in libltdl make[2]: Entering directory/home/.minilotto/paworama/src/clamav-0.96/libltdl’
Makefile:513: .deps/dld_link.Plo: No such file or directory
Makefile:514: .deps/dlopen.Plo: No such file or directory
Makefile:515: .deps/dyld.Plo: No such file or directory
Makefile:516: .deps/libltdl_la-lt__alloc.Plo: No such file or directory
Makefile:517: .deps/libltdl_la-lt_dlloader.Plo: No such file or directory
Makefile:518: .deps/libltdl_la-lt_error.Plo: No such file or directory
Makefile:519: .deps/libltdl_la-ltdl.Plo: No such file or directory
Makefile:520: .deps/libltdl_la-preopen.Plo: No such file or directory
Makefile:521: .deps/libltdl_la-slist.Plo: No such file or directory
Makefile:522: .deps/libltdlc_la-lt__alloc.Plo: No such file or directory
Makefile:523: .deps/libltdlc_la-lt_dlloader.Plo: No such file or directory
Makefile:524: .deps/libltdlc_la-lt_error.Plo: No such file or directory
Makefile:525: .deps/libltdlc_la-ltdl.Plo: No such file or directory
Makefile:526: .deps/libltdlc_la-preopen.Plo: No such file or directory
Makefile:527: .deps/libltdlc_la-slist.Plo: No such file or directory
Makefile:528: .deps/load_add_on.Plo: No such file or directory
Makefile:529: .deps/loadlibrary.Plo: No such file or directory
Makefile:530: .deps/shl_load.Plo: No such file or directory
make[2]: *** No rule to make target .deps/shl_load.Plo'. Stop. make[2]: Leaving directory/home/.minilotto/paworama/src/clamav-0.96/libltdl’
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/.minilotto/paworama/src/clamav-0.96’
make: *** [all] Error 2
schweppes:clamav-0.96->

Any pointers appreciated. I’ve tried various other flags to configure, but they don’t seem to make a difference to my problem.

Thanks.

Pat


#2

Try adding paths for make.

loc= $HOME export PATH=$loc/bin:$PATH export LD_LIBRARY_PATH=$loc/lib:/usr/local/lib:$LD_LIBRARY_PATH export LIBRARY_PATH=$loc/lib:/usr/local/lib:$LIBRARY_PATH export CPATH=$loc/include:/usr/local/include:$CPATH

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost