Problems installing Wordpress: "Directory NOT empty"

wordpress

#1

Hi,

I’m having issues trying to install Wordpress, or any other One-Click Installs (tried Concrete5 and Splash Frog as well) to my dreamhost registered domain. I am VERY green when it comes to all this domain/web registry stuff! I have gotten this email back from them on most attempts:

[i]We were unable to set up wordpress as requested at:

The problem was directory /home/redmaplefilms/redmaplefilms.com is not empty! Please re-install, specifying an empty (or new) directory.

Please correct this and go to our web panel and re-submit your
wordpress installation request.

Thanks, and sorry about that!
The Happy DreamHost Installer Robot[/i]

SO…how do I empty the directory or solve this problem?? I have tried deleting all my SQL databases and deleting/re-adding hosting to my URL. Obviously I don’t now what I’m doing. HELP!

Thanks


#2

Most likely the problem that you are having is that in the root or top level directory of a domain or sub-domain the dreamhost installer robot drops a few files as it adds the domain (like favicon.ico and the default coming soon page). Thus the top level directory of the domain or sub-domain is not empty.

The other reason the directory might not be empty is if you had already installed something there. Thus the error message would be trying to keep you from making a mistake, because there would surely be conflicts if you installed two applications to the same folder unless they were both designed to be installed to the same folder.

There are two ways to solve the problem.
1- delete those files via ftp or shell access before you request the one click install.
2- install to a folder… i.e. mydomain.com/wordpress (if you take this approach there is still ways to mask /wordpress/ out of the URL, but option 1 is probably simpler for a brand new site)


#3

(like favicon.ico and the default coming soon page)
These have nothing to do with it. After a new domain is set to fully hosting it is considered empty and WordPress should install like a charm on it.

That said best is to follow step 1 from above and delete everything (favicon.ico and.gif will be created again anyway)
then install best is custom install of WordPress


#4

I’m so disappointed. I likewise have been trying to use one click install for Wordpress for one of my sites. I keep getting the same error and there is absolutely nothing in the folder. Last time I did this on a website, I ended up installing the files manually. I was hoping to avoid that route. Can someone advise me as to why I’m getting this error consistently with every install I try? Thanks!


#5

I’m getting the same error. Can someone please tell me how to delete the items from the ftp to clear the root directory?
I can’t seem to figure it out.
Thank You


#6

Login via SFTP and rename the directory you are installing into, then create a new blank directory and give it the original name.

This works even on a main domain.tld directory.


#7

I have emptied my root folder completely and I am still getting the same error. What a pain! Suggestions?


#8

junkboy, I looked at all your domains and none of them are ‘empty’ (they all have a lot of files in them). If you want to tell me which domain is being problematic, I can take a look at that one.


#9

Yes, I had the same problem yesterday. I was trying to install the wp one-click in an old user name that i had from a long time ago and got the same error as you (davermf). Then I remembered I had installed to that name long ago, and so I made a new user and then moved the domain to the new user from the old one, and deleted the old one.
Voila! it worked! Am running WP now. Now for the work…

:slight_smile: