Problems accessing buckets via Cyberduck and others

dreamobjects

#1

First S3Anywhere began having problems several months ago. I get a “SignatureDoesNotMatch” error which their website says the key is incorrect. So I changed the secret key to one that didn’t have a - in it and tried again. It still does not work.

But I could still access via CyberDuck and SyncBack so I ignored it even though it is an issue. Especially since DH did away with the storage user.

Now Syncback is tossing weird errors although it does connect.

And CyberDuck cannot connect at all. Error says “Bad Request. Service Error Message. Please contact your web hosting service provider for assistance.”

I am using the new dream.io address.
I have checked the two keys.
I have uninstalled and reinstalled Cyberduck including the downloadable “helper” for Dreamhost. I have tried it with and without that helper.

I dislike the DH panel interface as it never shows all the buckets and really is a PITA to use. I much prefer CyberDuck.

So is there a problem or am I just not crossing my eyes enough? I hate submitting a ticket when it involves outside software so I thought I would ask here first.


#2

Sorry for the issues. It seems that some S3 clients are abandoning the AWS signature version 2 and this is something that we still implement. We have some good news though, that on September 20th we will be upgrading the Ceph software used for DreamObjects, which will provide AWS signature version 4 support and allow all these clients to work.

I don’t have a immediate workaround for S3Anywhere, but for Cyberduck there are a couple solutions:

  1. Download a version before 5.1.0 and install that, it will work fine. Click the 5.0.11 version you need for your system here: https://cyberduck.io/changelog/

  2. You can download their latest snapshot, and use this connection profile: https://trac.cyberduck.io/wiki/help/en/howto/s3#AuthenticationwithsignatureversionAWS2

Or the other option, wait until Wednesday after the maintenance and all should be good.


#3

Thanks. That explains it then. I’ll use the older version of CyberDuck in the meantime.
[hr]
And it works. Thank you!