Problem with subdomain and a Q on stats


I’m new to Dreamhost and like to know how to set this up.

For subdomains -
how do you make it so that the URL is and maintain it like that as they continue browsing that part of the site? eg (when they go to like dir1 the url will show I set up a subdomain but the only option close to what I want seems to be redirect but it just changes the URL to when I go to which is not what I want. Any help?

For stats -
Also for the stats page. I just started but I like to see the stats and how it displays it and all. I went to but all it says is “No input file specified.” Am I suppose to wait a month till I get to see my stats?


If you create a subdomain and place all your site files and folders, it should always stay on that subdomain, just like it’s a “regular domain.” Creating a subdomain can be done in your webpanel at Domains > Add Domain.

As for stats, you have to create a user account in your panel and specify the stats you want reported. This can be done in your webpanel at Status > Statistics. Once you’ve done this, I think you have to wait a day for the statistics to report.

I hope I understoood your questions correctly and helped a little.

Well when I created a subdomain I only had these options

  • Park
  • Domain Redirect
  • Display another site
  • Mirror Domain

I chose redirect but it just redirected to the directory “URL =” but I wanted to maintain the URL as “

I went to edit it and now I have an extra option of a full hosted domain (like my main domain). I switched to it but now I have to wait till the DNS updates. So I have to wait and see.

I seem to figure out my stats problem. Apparently I put in .htaccess. It doesn’t like this line…

AddType php-cgi .html .htm

I want my html files to be processed as php files. But it causes the stat page to fail. Anyway around it?


When I go to Domains > Add Domain, I have the box to type in the name of the domain/subdomain (type in I want to add and TWO buttons under it.

The buttons say: “Fully Host” or “Park/Mirror/Redirect”. You want to click on the “Fully Host” option. There will be two more screens you go through, but the panel will walk you through the rest (add the subdomain to your account, where your web directory is located, etc.).

You can make the domain stay static and not change when you click around by editing the web service for the domain and setting it to the ‘Display another site at your domain’ option. You can edit the web service by going here:

From there click the Edit link. You’d have to set up two subdomains to do it exactly the way you want. On the one you want to use, you pick the ‘display another site’ option and then put in the other subdomain as the site to mimic.

For the stats question, the stats show up the next morning after your website is first active. ‘No input file specified’ is a PHP error and that means you have done something to force .html files (the stats are .html) to be interpreted as php. Undo whatever it is you did and your stats will work again.

  • Dallas
  • DreamHost Head Honcho/Founder