Problem with MYSQL version

I am having a mega problem with ‘i believe’ the MYSQL versions. I dont know for sure so I need your input please.

I brought a script nearly a year ago which has been running just fine for me with MySQL - 4.1.15

However recently I decided to purchase a domain name and shift the entire script to it, its version is MySQL - 5.0.24a

Now the problem is the script dosent work with the new version but with the old it works just fine. And same with installation, it will install fine for the old version but for the new version it just does nothing.

Upgrading the script is not an option I want to take because the guys who wrote it wont allow ‘free upgrades’ anymore so you basically have to buy the new version at a discounted price for old customers and its pretty expensive.

So to cut the long speech short, is there a way for me to select which version of MYSQL a specific domain will use? Or not?


You can’t select an older version of MySQL. All new databases are created with version 5. Is your old DB here at DreamHost? Hopefully so and then you can keep using that one.

I don’t see a workaround for this.


Yes the DB is on:
Database On Server
p2p_forum bigglesworth

While whenever I create a DB for the new domain it gets created on:
cinnamon (server name)

But there is an additional problem I am facing - when I upload the script to the new domain and inside the config file specify it to connect to the DB p2p_forum, the script still refuses to function. It will connect to the DB but it just dosent log anyone in, refuses to even run the intall script. I dont know why.

Can you kindly shed some light into this, so I could try and resolve the issue? Because if there is no resolve then the only thing I can do is to point the new domain to the existing working installation.



I’m not meaning to question your earlier statements, but, from your descriptions of what is happening, I’m wondering if your problems might be more the result of running PHP5 than of the MySQL version.

Many “older” scripts are written in such a way that they need to be changed to work properly with PHP5. It could also be something as simple as the setting of register_globals or some other setting that is changed, by default, with PHP5.

I suggest you try to run the script with your domain set to use PHP4, and see if you have better luck. It just may solve your problem. :wink: .

You can change the version of PHP your domain uses in the control panel from the Domains–>Manage Domains screen - just click the “edit” button next to the domain, and check the radio button for PHP4.

You can always change it back if it doesn’t help. Good luck, and Merry Christmas.


WOW you were right on the button!!!

Changing the PHP version fixed everything :smiley:
Thank you so much! Script installed and problem resolved.

Merry Christmas to you too and best wishes!


That’s outstanding! I’m glad you were able to use your script; I’m sure that is a load of your mind. :wink: .

Merry Christmas to you, and have a great New Year!


Never can be sure about these things, but seeing that you started it I can understand. ROFL.

Ha ha ha! One too many “spiced rum eggnogs” making it’s presence felt there! :open_mouth: . You are absolutely right! (no, you, have a Merry Christmas!, NO YOU HAVE A…) Ha! That’s what I get for visiting the forums on Christmas day. :wink: