Problem with installing script


#1

Hello

I just switched to dreamhost a week ago and got a shared hosting plan. I’m trying to get my website to work and my domains are not transferred yet but I have it mirrored and this way I can view my page. But I’m having a problem with a script which worked with my previous host.

It’s a traffic trading script called turbo traffic trader. http://www.turbotraffictrader.com

Their web page says that the server requirements are:

Your server must be running apache with cgi-bin support.
Your server must have RedHat 7.3 , or FreeBSD 4.9 (other Linux/FreeBSD versions will probably work as well)

There are two versions to download I used the FreeBSD version on my previous host and it worked fine.

With dream host I tried the linux and freebsd version and none of them work.

After installation I try to run the admin program and many pages of code show up.

The code looks like this but a lot of it shows up:
ELF à¡ 4$l 4 ( 44€ 4€ ÀÀ ôô€ ô€ € € Àé Àé Àé Ày

I don’t know what’s wrong and what operating system the server I’m on has and what version. I’m on Laurel server.

Thanks for your help in advance


#2

Looks like you downloaded the compiled C version. You probably just need to set the permissions correctly - chmod 755.

Not sure what is wrong if you actually downloaded the PHP/MySQL version from this page:
http://www.turbotraffictrader.com/php/

:cool: Perl / MySQL / HTML+CSS


#3

Thanks for the fast response

I checked all the file and directory permissions and they are correct. All are set to 755 and other scripts are working except for this one. I chose the C version of the script because it supposed to be faster and it doesn’t need mysql database in order to work.

I’m not familiar with the types of programming languages and how they work but if a script is in C language does that mean it won’t work on dream host servers?