Problem with .htaccess in root


#1

I successfully installed a script in my new hosting account. I am facing a problem with the .htaccess file which is coming with the script.

The problem:

The URL rewrite mode is not functioning with my root directory of my website. Means www.mydomain.com. But i created a new directory in my root folder and installed another copy of my application again. (www.mydoamin.com/new_directory) Strange it works fine as my test server. I don’t know why it’s not worked in my root directory.

The real problem I found there when I try to login into my website as admin or any other account. A 404 error occurs.

Could anyone please help me how can I solve this?

Conclusion: .htaccess works fine with all sub-directories but not in root directory.


#2

Post your .htaccess file with any sensitive info xx’d out. Without that, you’re just going to get wild guesses.

-Scott


#3

I would like to post my .htaccess file here.


http://www.seasonsgreets.com/seasons_greetings/htaccess.txt


There are a lot there down so I couldn’t post here all.

Please analysis. There is no “Rewrite base” command there is that the problem?


#4

Scott is correct that we are only guessing without seeing you .htaccess file(s), but I’m willing to venture one guess:

Is there any chance you have inadvertently uploaded/created an .htaccess file in you user directory above your web base* directory?

–rlparker


#5

I have posted my .htaccess file here. Please have a look at it.

http://www.seasonsgreets.com/seasons_greetings/htaccess.txt


I have three directory in my ftp root access. Those are

myhosteddomain.com/myapplicationinstalled(.htaccess file is here)
logs
maildir

which directory I want to upload my .htaccess into. This is same problem happening in godaddy hosting as well.

for example:
I have installed the script on www.installeddomain.com/xyz/ This is working fine
Then I hosted a “new domain” and pointed to this directory to www.installeddomain.com/xyz.
Then I try to browse www.newhosteddomain.com.
Now the magic happened. it’s not working… showing cannot find the requested file, means 404 error appearers. What could be the problem?


#6

I’m sorry, but now I am totally confused regarding what you have installed where, which “test server” it “worked” on, and what is served from http://www.installeddomain.com, http://www.installeddomain.com/xyz/, and http://www.newhosteddomain.com/.

Am I understanding that you have “pointed” http://www.newhosteddomain.com to your /home/user/www.installeddomain.com/xyz/ directory by setting that as the “directory for your domain” in the Manage Domains section of the control panel?

Are you sure that “newhosteddomain.com” has been properly updated across the net in DNS so that it can be browsed?

I see nothing “obviously” wrong with the .htaccess file (and if it was provided with the script, you would think it would work if the application is correctly installed), but it is hard to tell without being able to browse to the involved domains and look at headers, responses, and such.

Is there a reason you cannot share the urls for the two involved domains so we can explore a bit?

It might also help if you shared what application/script this is. If it is something that is commonly available on the web (FOSS?), some of us may get a better feel for what is happening by visiting it’s site and looking at the documentation.

Have you contacted the author of the script, or checked on forums related to the script? DreamHost is such a large host and is used by so many people that it is highly likely someone may have already successfully installed the script on DreamHost and already worked out your problem.

–rlparker


#7

It appears you have edited your last message.

Is the http://www.seasonsgreets.com/ and http://www.seasonsgreets.com/seasons_greetings/ site what we are talking about here, or are you talking about different urls and/or different software?

Rather than try this directory structure, have you tried just installing the software directly into a www.newinstalled.com.com directory, in stead of “pointing” it to a subdirectory of the other domain?

Did you “point” the new domain at the subdirectory using a redirect subdir action in the panel?

Is the software you are having trouble with eCardMax?

–rlparker


#8

I am sorry to make confusing. Any way my seasonsgreets.com has installed by ecardmax and hosted with Godaddy.com. Here I am talking about a different software hosted with Dreamhost.

I would like to share my domain name here for better understanding. My domain name is www.iBoxtube.com. This one I hosted with dream host. I installed a third party video application called rayzz on this domain. The .htaccess script supplied by them. This is not working in the root directory of this domain.

So I installed this script on a subdirectory for testing purpose. So my testing script is running on www.iboxtube.com/test-tube. The .htaccess file supplied with them is working fine on this directory.

So please check the two version of the script with a login name with folowing domains

login name : test
Password : test
not working Domain : http://www.iboxtube.com/
working domain : http://www.iboxtube.com/test-tube/

I think this post will give you a clear idea what I am really facing. Please log with the above mentioned accounts with both installed versions. You will feel the difference.

Thanks in advance


#9

Thanks for straightening me out on all that, and it does make more sense now. Attempting to login at each of your urls, I understand the problem you are having, though a “solution” does not immediately present itself. :slight_smile:

This is most likely an install issue of some kind and, upon looking around the web, I found a couple of interesting things that might be relevant to your situation.

For instance, in the “reviews” of the script on hotscripts.com most users give the script good reviews, and good marks for support. Fewer users report report bugs in the script and poor experiences with support. One user reports that the installation instructions for the script has errors.

All that said, and given that this is a commercial script for which you have paid, I strongly recommend that you contact the script’s author’s support folks for help in getting this sorted it. They are likely to understand what’s causing the problem, and know how to fix, much more easily than anyone here.

That’s not to say I’m not willing to help, but without the code and the installation instructions (and with an indication that the installation instructions might be in error anyway), it just seem much more efficient for you to go to the author first.

The ability to do this is part of what you paid for when you purchased this script, and you should take advantage of that. You might also check to see if the author’s site has any support forums or online resources to help you sort this out.

–rlparker