Problem with actived rack


#1

I have a rails 3 web site that uses rack 1.2.3, when I try to access it I am receiving this error:

You have already activated rack 1.2.1, but your Gemfile requires rack 1.2.3. Consider using bundle exec.

Does anyone know how can I fix this?


#2

This is an old problem at Dreamhost. Yehuda Katz said: [quote]While [the .gems hack] solved the problem of top-level dependencies, it did not lock in dependencies of dependencies. This caused extremely common problems with rack and activesupport, and a long tail of other issues. One particularly egregious example is DreamHost, which directs users to use a brittle patch to Rails[/quote] that might or might not still work.