Problem Installing Mambo



I’m trying to install Mambo, but keep getting a username and password incorrect error (they’re not). No one on the Mambo forums had a solution and I was wondering if anyone came across this?


Installed just fine for me not to log ago. Sure you’re using the user ‘admin’ with the administrative password?

It’s been a bit since I’ve installed it, but I seem to recall that the username ‘admin’ was unchangeable.


Admin? Now I’m completely confused because it’s asking for the database username and password which is something different, isn’t it? I have a user set up for that particular database and that’s the name and pw I’m putting in.


If you are talking about the database username and password (You didn’t mention that in your original post) then make sure You aren’t using “localhost” as the database host in Mambo. You need to use the servername that was created when you created the MySQL database on your panel.

-Jason - Home Page
MP3Mystic - Personal Streaming Music server.
(Neither of these sites are still hosted at dreamhost)


Thanks for your responses, btw. I can’t figure it out. And yes, I did use the actual database name. I know that localhost doesn’t work on Dreamhost. I’m really perplexed since I’ve seen posts of people who’ve made Mambo work. I’m pretty much a newbie to this stuff, but I’ve installed scripts that require MySQL and this is the first time I’ve come across this problem.


I pulled out my notes from my successful installs of Mambo. Hopefully they’ll help.

First thing I did was create a new MySQL database and carefully record, the db name, dbhostname, username, and password. You’ll have to wait long enough for it to be created before you can perform the install.

Be sure you’ve gone into your webpanel and set your domain to run PHP-as-CGI.

Once files were installed in my domain folder, I went through the web browser install script.

According to the pre-install check, the only difference between the recommended and actual environment was that “Register Globals” was on, not off.

Accept the licensing.

Specify MySQL settings. As you said you know, you’re not supposed to use localhost. You should enter the db hostname from the database creation (should be in the form of Once this is done, Mambo tells you that propagation was a success!

Name site.

Accept URL and path. Mambo gives you an admin account. You’ll want to make sure you write down your login and password.

Once you’re done with that, you delete the install directory and have fun getting to know Mambo.

I hope this helps. If it doesn’t, let me know.


I think I found the problem, the run PHP-as-CGI wasn’t on for that domain. I changed that and it’s letting me install!

Thanks so much for your help!


Glad I could help. Have fun!

I need to get back to Mambo and experiment with templating.

Right now I’m in the middle of CivicSpace/Drupal.


I’ve just signed up as a new customer and hoped to find Mambo as one of the auto-installer scripts. Since it’s not there, does it mean it has to be installed and updated manually?



yep, you’ll have to do it your self. It’s not a lot of work to install scripts your self normally. Just follow the instructions and you should be good to go. Feel free to post questions along the way as well.



It does have to be installed manually, but it wasn’t really that difficult.

The step-by-step I posted above covers the main points of installing Mambo at Dreamhost. If you get hung up, I have some more detailed notes I took when I did it, so just post your questions on this board.


“According to the pre-install check, the only difference between the recommended and actual environment was that “Register Globals” was on, not off.”

Is it alright that Register Globals is set to on instead of the recommend off?


yes. You can run Mambo/Joomla with register globals on