Problem adding a domain


I went to ‘Manage Domains’, clicked on ‘Add Domain/Sub Domain’ and tried to add

I get the following error.

“Can’t add domain: you don’t have permission to add”.

Please let me know how to proceed.


That message usually means you don’t have a Hosting Plan. I was able to add in the panel.



but I do, have a domain hosted there already.


Tried again, but doesn’t work. What could be wrong?


There is a major problem going on (but definitely not for all users), we have lost all our domains, and all of our users from the panel. However, the web sites work, and we can ftp to them. Mail can be sent, but any mail coming in gets bounced back to the sender. No response from support yet.
I suspect the system 'homie’


I still have the same issue, can’t add a domain. Is this the right place to ask for support?

I need to add a .in domain which I’m unable to and the error that it spews all the time is “Can’t add domain: you don’t have permission to add”.

I already have a domain hosted on my account and the account info says that I can host unlimited number of domains.

So what’s going wrong?

  • Pratik


Submit a ticket to Support. Adding a .in worked for me, and it should work for you.