Private directory and hotlinking


#1

i’ve been looking through the forum and I found a lot of helpful info, thank you all. but I have one issue that is causing me problems.

my web site is www.alloverphotos.com and with the help of some books and everyone on here I’ve got my gallery working great. it’s just a beginning but it works.

anyway, I’ve got a sub directory called private and i’ve set that up to be password protected. basically photoshoots that I do with models I will have under this directory so that only people I give the password to will be able to view it. and again, with help from this forum I got that working.

BUT, here is the kicker. I want to also be able to hotlink some photos to message boards and on myspace but when I try that it asks for the password of course. I basically want it to work like photobucket where I can hotlink a photo but if someone goes back and tries to look in that directory they can’t. I’ve read about the .htaccess and it seems like I might be able to do something in there, but I’d have to edit it via a text editor…I’m on a windows machine and that file does not show up. can anyone help?


#2

You could copy the pics you want to hotlink into a new directory without password protection.

In .htaccess put
options -indexes

Actually you can do this in the panel, and even build a list of other specific sites you want to allow to hotlink.

You need to turn on displaying hidden files with whatever you’re using, to see .hidden files.

[color=#00CC00]ANONYMOUS0=>Max Discount[/color] [color=#6600CC]ANONYMOUS2=>Max - $1.[/color] Being mean doesn’t make you look smarter than him. And bigoted remarks are not appreciated on this forum.


#3

well I still need them to be in some kind of protected directory so I can’t just move them. but on a side note, I did just try making another directoy that isn’t password protected. I had to check the box that forbids linking and then I put in a couple sites that I want to be able to link and it’s still not working. the linking itself doesn’t work.

edit: I got it to work on myspace (the one without the password protection) but not a message board I frequent. It made all file types forbidden but default so I just added in .psd and then the .jpg file i had uploaded worked. still can’t get it to work on the protected directory though.


#4

ok, weird. I got the non protected directory to work but I have to add in the entire http:// into the tags to get it to hotlink. if I leave that part off it doesn’t work. not a big deal. ok, so back to working on the protected one. i’m trying to do some reading.


#5

See Module mod_access and Module mod_setenvif.

You will need to use a combination of directives: Satisfy, Allow, and SetEnvIf

:cool: openvein.org -//- One-time [color=#6600CC]$50.00 discount[/color] on [color=#0000CC]DreamHost[/color] plans: Use ATROPOS7


#6

Just to be sure I’m not confused: you’re doing this with a homebrewed system, not the Gallery software, right?

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#7

ok, I think I got it to do what I want.

ignore the gallery for now. that was just to test and make sure I could at least get an actual web site to work. thats going to change big time.

what I had to do (with some help from a friend that also has service here) is to right click on the private folder (in the ftp program) and go to properties. I unclicked the “read” checkbox under “groups” and “others” but left the “execute” box checked. now for example of someone goes to http://www.alloverphotos.com/private/7mile.jpg they will see the photo AND I am able to hotlink it. however if you try to go to http://www.alloverphotos.com/private/ you get the error message. at least it seems to be working…please let me know if it’s not.