Presta Shop Installation/File Permissions


#1

I am trying to install Prestashop on a Dreamhost server. I have followed the instructions here:
http://www.prestashop.com/wiki/External_or_Friendly_URLs
to allow friendly urls which seems to have worked properly.

The problem I have is I get an error during the “System and permissions” stage of installation. “Write permissions on folders and subfolders/recursively: /themes/prestashop/lang” comes up as red and wont allow me to continue.

I have tried chmod 777 on that folder and all the files in it which didnt work so I deleted the folder, recreated it, chmodded it then added the files back in which also didnt work.

Any suggestions?


#2

/themes/… would be off the server’s root directory, which we don’t have permission to write to. Something seems to have set the path to root, instead of ~/yourdomain.com (or /home/USERNAME/DOMAIN.COM/themes/…

Unless this is all relative to the root of your domain. Does the red flag give you any more information? Is there some sort of log within Prestashop you can check for errors? Or even an option to turn on Debugging?

-Scott


#3

Sorry I should have said it’s relative to the root of the domain.

Here’s a screenshot of the error:
http://img151.imageshack.us/img151/3109/20417323gx4.jpg

There is no log or debugging mode in Prestashop that I can find, this is pretty much the first step in the installation process.


#4

I’m still thinking it’s a permissions issue. I use shell access, and would go to /themes/prestashop and do a “chmod -R ugo+rw lang” to give everybody recursive read/write permissions to that directory.

My FTP program (Transmit) also lets me do recursive permissions changes.

-Scott


#5

I’ve tried shell access using putty (with the command chmod -R 777 lang/). I have also used filezilla and dreamhosts’ webftp to try and make the change.

I tried your command (chmod -R ugo+rw lang) and this also didnt work.

When I look at the folders/files in filezilla or webftp they are showing as having full read/write permissions for that folder and everything in that folder.


#6

It looks like someone in the PrestaShop forums had the same problem, but worse, and didn’t post a solution. I suggest you hit the forums over there and see if someone else has had the same problem, or found a solution.

http://www.prestashop.com/forums

-Scott


#7

I’ll try the forums there.

Thanks for your time Scott, much appreciated.