Preserve mtime in ftp account

I set up a ftp account for a group colleagues so they could exchange drafts and data while working on a project. They use PCs and windows FTP apps or windows explorer to move files in and out of the directories on the ftp site. One of these guys was just asking me if there was a way to preserve his file dates for new stuff he puts into the ftp directories so everyone can see which drafts are the newest. My first thought was “No, you can’t” but if you tarred up the files then untarred them on the FTP host, the mtimes would be preserved, like the old UNIX trick to move files around with tar to preserve mtimes and permissions. I initially thought if he tars or zips the files and moves them to the ftp directory, I could ssh in and unpack the files. But, crap, how can I log into an FTP only user account? Maybe I need to set up a shell account for these guys to FTP to, so I can get in and unpack stuff. Or is there an easier way?

This signature line intentionally blank.

Enable shell access to the shared user.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost

I can add shell access to a FTP account?

This signature line intentionally blank.

If you have access to the DreamHost panel, then you can turn an FTP account to a Shell and FTP account. Go to Manage Users and click Edit in the last column. From there, you select what access you want the user to have.


Really? Cool! I haven’t painted myself into a corner then.

This signature line intentionally blank.

Most ftp clients have an option to “preserve file time” which may or may not be enabled by default. I’d suggest having them look for that sort of setting in the application they’re using.

My colleges are using WS_FTP Pro 12 from Ipswitch. There is an option in the connection settings to Preserve filetime on upload, but that MDTM must be supported on the server. I’ll have to look up MDTM. I couldn’t make this work with uploads to

From a command line, ftp to replies to ftp quote mdtm filename with 213 20070317001409 so there is some level of MDTM support on the server.

However, there is this earlier post that seems to indicate that WS_FTP doesn’t work this way: [url][\url]

This signature line intentionally blank.