Pmwiki

apps

#1

I’m trying to install pmwiki. Note - I’ve never installed it before.

I followed their instructions and it appears to be installed and it created the wiki.d directory.

I get a default page. All the links return an error page:


Warning: Unexpected character in input: ‘’ (ASCII=15) state=1 in /usr/local/dh/cgi-system/php.cgi on line 4122

Parse error: parse error, unexpected ‘*’ in /usr/local/dh/cgi-system/php.cgi on line 4122

What does this mean?


#2

seems to me (though I have no expirence with this software) that you didn’t set a path properly. You don’t have access to /usr/local/* on your server. That should look somethign like /home/user/domain.com/cgi-system/php.cgi

Edit:
Check out this page in the wiki. Perhaps this is all you need to change to get things working

-Matttail


#3

Registered now…

Thanks. I found that page myself a few minutes after I posted here! :slight_smile:

Realizing that, based on your own admission, you are not the best person to ask this, I hoping someone else will read this, or you can take a stab at it again, you were right on last time :slight_smile:

I added both lines:

$ScriptUrl = ‘http://’.$_SERVER[‘HTTP_HOST’].$_SERVER[‘SCRIPT_NAME’];

$ScriptUrl = ‘http://’.$_SERVER[‘HTTP_HOST’].$_SERVER[‘PHP_SELF’];

Which by itself is a little wierd, because they’re both to the $ScriptUrl variable. Viewing and even editing worked, but I’m not able to use pmwiki’s skins facility because another variable needs to be defined according the sample-config.php file, $PubDirUrl.

But I don’t know what path it’s looking for. I tried the obvious http://www.domain.com/pathtopmwiki/pathtopub and that didn’t work.

Any ideas?

Thanks


#4

So here’s the solution.

Edit the local/config.php to have the following lines:

$ScriptURL = ‘http://www.domain.com/pmwikidirectory/pmwiki.php
$PubDir = ‘http://www.domain.com/pmwikidirectory/pub