Please Help! https: ssl getting error possible .htaccess issue

software development

#1

I am new to Dreamhost and have been struggling getting our https: to work on our site. At first we thought it was the custom install of php5 and APC but after uninstalling APC we have come down to maybe a problem with our .htaccess file.

When accessing a simple html file in the root directory via https: we get the following error:
Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace.

When we access it through the http: it works fine.

The following is the .htaccess in the root directory of our site:


Options +ExecCGI

AddHandler php5-cgi .php
Action php5-cgi /php5/php5.cgi
Action application/x-httpd-php5 /php5/php5.cgi
AddType application/x-httpd-php5 .php5

<FilesMatch “^php5?.(ini|cgi)$”>
Order Deny,Allow
Deny from All
Allow from env=REDIRECT_STATUS

SetEnvIfNoCase Remote_Addr ^64.92.148.92$ MODSEC_ENABLE=Off


We have a custom php install based on a wiki provided by Dreamhost: http://wiki.dreamhost.com/PHP_5_install_script

And have commented out of the php.ini everything to do with APC from the following Wiki install: http://wiki.dreamhost.com/Pecl_APC

Not real sure where the SetEnvIfNoCase line came into play. But not sure if it is okay to delete it either.

Just Really need another set of eyes to look at this and give me an idea and/or direction as to how to get it resolved.

Many Thanks in advance!!!


#2

Ok, I went ahead and eliminated ALL the custom php stuff and set everything back to Dreamhost’s managed settings and still not getting access to any files through our https: ssl access.

Certificate says it is installed through the Control Panel. Don’t know where to go from here. Hoping that Support will look at it and not give me the canned response of “its your code”

Any suggestions would be greatly appreciated.


#3

Got it resolved!

After three days of complete hell and freaking out, it came down to a single button. Posting this to save the next person the same frustrations.

If by some reason you have decided to add a SSL certificate after setting up your site make sure you check the checkbox next to “Mirror non-secure settings?
Use the same settings as your non-secure hosting”

So simple, yet SOOOOO Frustrating ! !

Thanks to Trey with support to finally realize that was the issue.