Planet no longer working

apps

#1

Have been using Planet for a while to scrape & aggregate some RSS feeds - has worked perfectly from installation up until a few days ago, when it stopped updating and started producing errors everytime cron ran the script. Haven’t made any changes myself, and Dreamhost support tell me nothing has changed at their end, so I’m at a bit of a loss as to what’s gone wrong.

Here’s the error output ( and substituted for the real thing):

Traceback (most recent call last):
File “/home///planet/planet.py”, line 167, in
main()
File “/home///planet/planet.py”, line 160, in main
my_planet.run(planet_name, planet_link, template_files, offline)
File “/home///planet/planet/init.py”, line 240, in run
channel = Channel(self, feed_url)
File “/home///planet/planet/init.py”, line 527, in init
self.cache_read_entries()
File “/home///planet/planet/init.py”, line 569, in cache_read_entries
item = NewsItem(self, key)
File “/home///planet/planet/init.py”, line 845, in init
self.cache_read()
File “/home///planet/planet/cache.py”, line 73, in cache_read
self._value[key] = self._cache[cache_key]
File “/usr/lib/python2.5/bsddb/init.py”, line 223, in getitem
return _DeadlockWrap(lambda: self.db[key]) # self.db[key]
File “/usr/lib/python2.5/bsddb/dbutils.py”, line 62, in DeadlockWrap
return function(*_args, **_kwargs)
File “/usr/lib/python2.5/bsddb/init.py”, line 223, in
return _DeadlockWrap(lambda: self.db[key]) # self.db[key]
KeyError: ‘http://sandbox.zimcricketnews.com/2011%20at%20http://sandbox.zimcricketnews.com comments’

Anyone familiar with Python or Planet able to shed any light?


#2

That sounds like there may be some bad data in Planet’s cache which is tripping it up. I’m not familiar with the software, but if there’s some sort of cache directory, try emptying it out.


#3

Good call - problem solved. Many thanks!