PIWIK cronjob Help Needed

I’ve just installed Piwik. While reading the manual I found an area that I believe requires me to set up a cron job. What prompted me to do this was the below comment in the manual.

I receive about 1,000 unique visitors a day, so my visits are over a few hundreds per day. I would like to do what is best, and it is suggested that I automatically archive. I visited this forum and another and I read that Piwik automatically sets up this auto archiving, but then I also read it does not. Can someone confirm whether it does or not? If not then I must set it up.

While following the steps listed in the manual I became confused when I am to set the minutes to 00, but do not know if I have to set the day, the hours, month and day of week. Do I just totally ignore those and as long as I have 00 highlighted in blue and click the ADD button … that is all I need to do in that section?

If someone would be kind enough to offer me a few tips on setting this up I would be grateful. I just need confirmation that my assumptions are correct, and if not would you be so kind to offer the solution? I will be doing this from within my Dreamhost Cpanel while under the Cron Jobs section.

The steps it suggests I follow are:

[quote]It is easy to setup Automatic Archiving if you use a user interface such as CPanel, Webmin or Plesk. Here are the instructions for CPanel:

Login to cpanel in the domain with the install
Click on “Cron Jobs” in the domain with the install
Leave email blank
In ‘Minutes’ put 00 and leave the rest blank.
You then need to paste in the path to the archive.sh file.
Here is an example for a Hostgator install (in this example you would need to change ‘yourcpanelsitename’ to whatever your particular domains cpanel username is)[/quote]

Here are the areas I must fill in for the first steps for the cronjob within my Cpanel in Dreamhost:

Please note I only used capital and bold to make it easier for review

(shell users only!)

A friendly name for this cronjob

Email output to: b[/b]
Leave blank to disable sending emails

Command to run (max 1000 characters): /home/mynicknameonhost/mydomainname/piwik/misc/cron/archive.sh
Is this correct? (of course I will put my correct info into this line)

Use locking: (IS CHECKED)
Prevents this job from running more than once at a time. This is generally a good thing!


Minutes: (SET IT TO 00)
Hold ctrl (windows) or command (Mac) to select multiple values:

Hours: (Every Hour?)

Day of Month: (Every Day?)

Month: (Every Month?)

Day of Week: (Every Day of Week?)

[color=#FF0000]Thank you in advance for your help.[/color]

The dreamhost admin page is pretty easy to fill out. It’s even a little easier than all the things you specified becasue the last option is “run hourly” on the hour in a drop down box, so you really don’t need the “custom” choice… just hourly… https://panel.dreamhost.com/index.cgi?tree=goodies.cron&current_step=Index&next_step=ShowAdd

have you tried to set this up yet? It’s pretty simple, jsut post back when you run in to trouble.

Okay, the Piwik manual suggested setting it to 00, so setting it to 00 in minutes is not needed, but rather skip that and just go with hourly? Just to clarify what you said.[hr]
When I try to run it I get invalid user.

on the top dropdown box did you pick your shell/ftp user for the same domain the file is in?

Yes, setting ‘hourly’ in this case is the same as your 00 for minutes, but is much simpler.

The drop down is not working properly. It seems as if half is cut off. There is nothing to choose. Please note above in my original post it says

(shell users only!)

It was left blank because on only a very small section of the drop-down is showing, and there is nothing to choose. You cannot type either.

crontab -e

you can edit it yourself

crontab -e?

Please understand I have no idea of what you are suggesting.

then it’s probably better to use the panel.

your user is probably configured for ftp access only… it needs to be a shell/ftp user. then you will be able to select it in the dropdown.

I do not want to break forum rules and post any links without permission. I did take a screenshot and placed it on image shack. If you would like you can visit it to see what I am seeing. I can private message the URL to you if you like.

I do not have any experience with setting up cron jobs, and yes it seems fairly easy to do, and I am sure I could get this going, but it states invalid user when I go to ADD the cronjob. Yes, it sure seems like it is an invalid user because there is nothing to select for “USER” and my screenshot shows this. There is nothing in the drop down choices and it seems the box only 5px wide (strange)

Okay, I will go check that to see if I am set to FTP only. Thank you :wink: I feel as if I am getting somewhere now.

see above your post… we posted at the same time… the user dropdwn is proably empty because your user is configured ftp only… you will need to change that first.

Nice! I set it to shell/ftp and when I went back to cron jobs, and to set up the new cron job I could see it was already set up for me.

I guess this was done by default when Piwik was installed. I am glad you all were available to help me.

Thanks again