Pine no longer receiving mail


#1

Hi there …

As of last night, my pine sessions are no longer retrieving new mail. they see the old mail just fine though. I can access things fine through my webmail and my iPhone, just not via pine via ssh to my dreamhost account.

I got an email about them changing my email server, but the advice was to make sure I was using my host and not dreamhost.com - and I already was doing this

Any ideas?


#2

[quote]As of last night, my pine sessions are no longer retrieving new mail. they see the old mail just fine though. I can access things fine through my webmail and my iPhone, just not via pine via ssh to my dreamhost account.

I got an email about them changing my email server, but the advice was to make sure I was using my host and not dreamhost.com - and I already was doing this[/quote]
Maybe you already did this, but did you check the inbox-path setting?

To check the setting, from Pine main menu press S for Setup then C for Config.

Example settings given domain is example.com, and my mailbox user is atropos7@example.com

hostname = mail.example.com
user = atropos7@example.com

{hostname/user=user/imap/notls/novalidate-cert}INBOX

{mail.example.com/user=atropos7@example.com/imap/notls/novalidate-cert}INBOX

Customer since 2000 :cool: openvein.org


#3

Ah, I was thinking that the inbox path might be the culprit but wasn’t sure what the entry would be. That does work, thanks.

On a side note, when it asks for the PW now, it gives a warning of being insecure, it used to check the PW securely. Is that something settable, or is that just how life is now?


#4

Outgoing is still fubar.

I used to have stmp-server blank, to use sendmail.

I’ve tried a few different configurations, all of which give me all sorts of hassle pointing at the wrong mail servers (my old one). Right now I’m using:
stmp-server=mail.foo.com/notls/novalidate-cert/user=me@foo.com

Does that look right?


#5

No. Here is a reference:

http://www.washington.edu/imap/documentation/naming.txt.html

Use /tls flag instead of /notls

Customer since 2000 :cool: openvein.org


#6

Oof, that works.

The downside is that I now have to enter my password:

  1. on starting up pine
  2. on the first time I Compose
  3. on the first time that message is sent.

Makes me kind of long for the days when you could have a password file to use.


#7

Who says you can’t use one now?

The file is ~/.pine_passwd

If you don’t have one, then use the command ‘touch ~/.pine_passwd’ and Pine will ask to save password to disk.

Customer since 2000 :cool: openvein.org


#8

Hmm, I thought they got rid of that about a year ago? I used to have one and received a notice a long while back that they were getting rid of it.

Yeah, I just tried it and it ignored the .pine_passwd file. Need something like that, it’s pretty unusable with the number of times I’m getting prompted for my password.


#9

See if this helps:

http://www.dreamhoststatus.com/2009/03/09/email-login-changes/#comment-233529

You have to use vim or nano on .pinerc to change folder-collections

Eric

Customer since 2000 :cool: openvein.org


#10

Aha! Thanks again, that did the trick.

Of course, the comment after that one isn’t very promising. One of the main reasons I went with DH was the shell access & pine, if they take it away, I don’t have much reason to continue to use them.


#11

[quote]Aha! Thanks again, that did the trick.

Of course, the comment after that one isn’t very promising. One of the main reasons I went with DH was the shell access & pine, if they take it away, I don’t have much reason to continue to use them.[/quote]
Well they are taking away the ability to bypass the interactive password prompt for security reasons. I don’t think Pine will be taken away - it just has to be configured differently as a result of separating mail service onto dedicated mail servers where the mailbox is not part of the shell user anymore. IMAP and certain conventions have to be used with different credentials as a result.

Customer since 2000 :cool: openvein.org