picKLE script problem?


#1

I was wondering if anyone else has set up a picKLE gallery on a dreamhost server ( http://picklegallery.sourceforge.net ). I know ImageMagick (a requirement) is already installed on the servers, and I’d love to use this gallery, but I’m running into problems. The script successfully creates a directory in “picKLE-cache” for each directory I create in the “picKLE-album” directory, but it never seems to actually generate the thumbnails or copy any other files into “picKLE-cache.” I end up with empty directories. Figuring I’ve just been a wank and missed an obvious step, I’ve quadruple checked the permissions on “picKLE-cache” to make sure it’s 777 like the script wants. So, what am I doing wrong here? RTFM suggestions are always welcome.


#2

Hi bix -

[quote]I’ve quadruple checked the permissions on "picKLE-cache"
to make sure it’s 777 like the script wants.

[/quote]

This is probably the problem. chmod the script to 755, as well as its containing directory. Our system is set up in such a way that scripts cannot be world-writable, as this is a security flaw just waiting to happen.

Even if the documentation says to chmod 777, it generally should still work if you use 755. Give it a shot and let us know what happens.

  • Jeff @ DreamHost
  • DH Discussion Forum Admin

#3

Now I am having this same problem, with pickle.

I’ve chmodded all pickle related files and directories to 755 just take make sure (used the recusive command) but I’m still getting error messages from the script. I’ve turned on error reporting, and it can be viewed from
http://alex.turnlav.net/TESTING/pickle/picKLE-0.3/

it seems to still be reporting a permission denied problem.
what can I do to make it work?


#4

I use several scripts that fail miserably unless some of the directories are set to 777. Or is it just the scripts that should never be set to 777? All my scripts seem to work fine at 755, but they often have directories that require 777. Still makes me nervous.


#5

that seems to fix part of the problem, less errors are showing up now, but i’m still getting problems like

Warning: sort() expects parameter 1 to be array, null given in /home/.jeno/turnlav/troop85.net/pickle/index.php on line 204

check it out:
http://alex.turnlav.net/TESTING/pickle/


#6

The /.jeno/ part in the error message usually spells trouble for me. I don’t know anything about pickle specifically, I find that scripts with semi-automated installs often pick up the .foo part of the path, which almost never works for me. If there is an automatically-generated configuration file in the pickle setup that includes .foo you might try editing it to delete that part. In other words, instead of /home/.jeno/turnlav/ edit it to use /home/turnlav/


#7

[quote]I use several scripts that fail miserably unless some of the
directories are set to 777. Or is it just the scripts that should
never be set to 777?

[/quote]

Technically, this is okay - the restrictions only affect the execution of the scripts themselves. However, if there’s anything “sensitive” in those directories I would be a bit worried. Most likely it’s okay, but I kind of wonder what reason there would be to even have such loose restrictions in the first place.

  • Jeff @ DreamHost
  • DH Discussion Forum Admin

#8

yeah, there’s no options in the config for that . . .
i guess i’m stuck


#9

[quote]but I kind of wonder what reason there would be to
even have such loose restrictions in the first place.

[/quote]

Most of the ones I’ve run into – it’s because the script checks for it rather than because it actually needs it.