Phpwiki doesn't work

apps

#1

phpWiki claims to work “out of the box”, just untar and install. I’ve tried it both like this and changing the directory for the db files to something in the phpWiki dir (from the default of /tmp). Either way, when I hit the directory from a web browser I get an empty page. Viewing source, I see that it got as far as the following, then, nothing. Any ideas?

I’d try using MySQL but apparently I can’t create databases right now.


#2

Sorry, this is with 1.2.4 (stable) downloaded off sourceforge.

And a similar error (just opening and closing html and body tags) with 1.3.10.

Errors occur whether PHP is set to run as CGI or not.


#3

phpwiki 1.2.4 seems to work with MySQL, but 1.3.10 generates the exact same blank page after being properly configured (I’ve triple-checked). Any help on this would be appreciated.


#4

yes!! I’ve done exactly the same thing - can’t get it to work at all it sucks…

if anybody at DH is reading this - please can you let us know if there is any other configuration options we need to put in. Or if anybody else has had experience with phpwiki 1.3.10… please post how you got it working… thanks…


#5

Having similar issues this week – I’m fairly comfortable installing PHP stuff, but I’ve never had this much trouble getting any PHP program to work. I sent my errors to DH tech support, and their response was I didn’t give the system time to create my database.

Well, I had…

Now when I go to [path]/admin.php and put in the username and password I indicated in the config.php file, I get the same Login prompt dialogue box over and over again (looks like the .htaccess password-protected directory login dialogue box).

Is there anyone who’s had success installing phpwiki on DH?

Has anyone ever seen 1-2-3 install instructions for phpwiki?


#6

I installed it fine. Didn’t know what to do after but I got the first page up and running.
I changed these lines in lib/config.php

Line 50: $WhichDatabase = ‘mysql’;
Line 111: $mysql_server = ‘db.domain.com’;

// username as used in step 2 of INSTALL.mysql:
$mysql_user = ‘’;

// password of above user (or leave blank if none):
$mysql_pwd = ‘’;

// name of the mysql database
// (this used to default to ‘wiki’ prior to phpwiki-1.2.2)
$mysql_db = ‘’;

Seems to want to use cgi bin, even if I’m using a database.

I created my database using the supplied schema in schema/schema.mysql


#7

I was trying to install PHPWiki earlier this morning but kept running into problems so rather than beating my head in I went to find a different WikiEngine.

I found MediaWiki to be a very straight forward install. Much like WordPress. So, if you’re still having problems you might give that a try.


#8

I agree. PHPWiki is a pain to install compared to pmWiki.

I was running into the same error when I tried PHPWiki “out of the box.” I finally did get it to work -

  1. Compiled my own version of PHP so the CGI doesn’t give unexpected script path results. (see full details on my site at http://www.nosq.com/2004/12/rolling-my-own-php-cgi-on-dreamhost/ )

  2. Un-tar’d a clean download of PHPWiki.

  3. Edited the ./config/config.ini file by hand to use mySQL instead of DBA. (Using DBA didn’t work out of the box.) Most other settings remained the same.

  4. Ran the ./schemas/mysql-initialize.sql script to create tables.

  5. Went to the root of the PHPWiki install directory and saw it actually work.

Since then I’ve run into a few other bugs in PHPWiki (which I’ve been able to fix by hand), but at least it’s working now. Don’t know if I’ll keep it. Have to do more testing first.